Bug 55049 - Upgrade to RH7.2 Doesn't Upgrade kdebase
Upgrade to RH7.2 Doesn't Upgrade kdebase
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 59389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 17:24 EDT by Coy Krill
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-05 16:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Coy Krill 2001-10-24 17:24:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
The upgrade left kdebase 2.1.1 installed on my RH7.1 machine and kdebase
2.2-9 installed on my Roswell-2 machine.  I tried to manually install and
received the following:

[root@merkava config]# rpm -Uvh /var/spool/up2date/kdebase-2.2-12.i386.rpm
Preparing...                ########################################### 
[100%]
   1:kdebase                error: unpacking of archive failed on file 
/usr/share/config/kdm: cpio: rename failed - Is a directory

The error is the same on both machines and happens when rpm is about 77%
installed. /usr/share/config/kdm is indeed a directory containing kderc. 
There is also a soft link named kdm;3bd72c8e that points to
../../../etc/kde/kdm .  I've even tried removing the directory and the soft
link and still receive the same message.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade current RH7.1 or Roswell-2 machine
2.check what version of kdebase is installed
3.
	

Actual Results:  kdebase 2.2-12 was not installed.

Expected Results:  Rpm should have installed kdebase 2.2-12

Additional info:

I tried to manually install and received the following:

[root@merkava config]# rpm -Uvh /var/spool/up2date/kdebase-2.2-12.i386.rpm
Preparing...     ########################################### [100%]
   1:kdebase     error: unpacking of archive failed on file
/usr/share/config/kdm: cpio: rename failed - Is a directory

The error is the same on both machines and happens when rpm is about 77%
installed. /usr/share/config/kdm is indeed a directory containing kderc. 
There is also a soft link named kdm;3bd72c8e that points to
../../../etc/kde/kdm .  I've even tried removing the directory and the soft
link and still receive the same message.
Comment 1 Bernhard Rosenkraenzer 2001-10-24 17:50:43 EDT
Upgrades from betas are not supported and not even supposed to work.

[root@locutus root]# rpm -q --changelog kdebase |grep -A5 2.2-6
* Tue Aug 21 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-6

- Move /usr/share/config/kdm to /etc/kde/kdm, fixes #51095
  IF YOU ARE UPDATING FROM A VERSION BETWEEN 2.2-0.alpha1.1 AND 2.2-5,
  REMOVE THE OLD PACKAGE BEFORE INSTALLING, OR rm -rf /usr/share/config/kdm
  FIRST!

Comment 2 Coy Krill 2001-10-25 01:04:50 EDT
Okay, sorry I even mentioned Roswell.  I first experienced this on my REDHAT 7.1
machine with full errata installed.  Using the upgrade to 7.2 left
kdebase-2.1.1-8 from REDHAT 7.1 still on the machine.  It was quite nice enough
to install kdebase-devel-2.2-12, however, it did not, and will not install
kdebase-2.2-12 for the previously mentioned reasons.  Uninstalling
kdebase-2.1.1-8, kdebase-devel-2.2-12 and removing all the partially installed
files from kdebase-2.2-12 does not fix the problem, kdebase-2.2-12 will still
not install.

If this is NOT a bug, then what is it?
Comment 3 Coy Krill 2001-10-25 01:09:00 EDT
BTW, I forgot to mention that /usr/share/config/kdm and /etc/kde/kdm are the
same file.  I did try the move and when I delete one, the other disappears as
well and no, kdebase-2.2-12 will still not install.
Comment 4 Coy Krill 2001-10-25 01:43:58 EDT
Hmmm, /etc/kde and /usr/share/config are hardlinked to each other. rpm shows
kdelib and kdeutils as both owning /usr/share/config and no owner for /etc/kde.
I just removed them and reinstalled them with kdebase and it all seems to be
working, now.  sorry for the inconvenience and multiple updates.

Coy
Comment 5 Ben LaHaise 2001-11-02 14:35:12 EST
Bero, this happens for me too on an out of the box RH7.2 install with up2date
-u.
Testing package set / solving RPM inter-dependencies...
########################################
Retrieving selected packages...
kdebase-2.2-12.i386.rpm:    ########################## Done.                   
########################## Done.                   
Preparing...                ########################################### [100%]
   1:kdebase                warning: /etc/ksysguarddrc created as
/etc/ksysguarddrc.rpmnew
error: unpacking of archive failed on file /usr/share/config/kdm: cpio: rename
failed - Is a directory
[CVSROOT=:ext:bcrl@devserv:/mnt/devel/CVS]
[bcrl@bob ~]$ 
Comment 6 Ben Levenson 2002-02-06 16:26:29 EST
*** Bug 59389 has been marked as a duplicate of this bug. ***
Comment 7 dharter 2002-04-04 18:24:09 EST
This happens to me.  I was manually updating for the latest upgrades and bug
fixes for 7.2.
I had done all the upgrades until about November 2001.
When I tried to upgrade the XFree base package it said:
unpacking of archive failed on file /etc/X11/xkb:cpio:rename failed is a
directory.
When I do an strace and look at the output the filenames seem to have a ; and
some alphanumeric string attached to them.
Comment 8 Ngo Than 2004-04-05 16:12:43 EDT
it's fixed in current release

Note You need to log in before you can comment on or make changes to this bug.