Bug 550630 - KDE "ihatethecashew" widget cannot be added to desktop
Summary: KDE "ihatethecashew" widget cannot be added to desktop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-plasma-ihatethecashew
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Eli Wapniarski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-12-26 14:39 UTC by Dave Ulrick
Modified: 2009-12-29 05:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-29 05:55:06 UTC


Attachments (Terms of Use)
Screenshot of error message (13.42 KB, image/jpeg)
2009-12-26 14:39 UTC, Dave Ulrick
no flags Details

Description Dave Ulrick 2009-12-26 14:39:01 UTC
Created attachment 380427 [details]
Screenshot of error message

Description of problem:

KDE ihatethecashew plasmoid cannot be added to desktop.


Version-Release number of selected component (if applicable):

kde-plasma-ihatethecashew 0.4-1.fc11.i586

How reproducible:
Try to add plasmoid to desktop, get error message.

Steps to Reproduce:
1. Right-click on KDE desktop and select Add Widgets.
2. Left-click on the "i HATE the cashew!" widget and click on Add Widget.
3. An error message is added to the KDE desktop:

This object could not be created for the following reason:

Could not find requested component: ihatethecashew


  
Actual results:
The widget is not added to the KDE desktop and the "cashew" remains on the desktop.


Expected results:
The widget is added without error and the cashew disappears.

Additional info:

$ rpm -ql kde-plasma-ihatethecashew.i586
/usr/lib/kde4/plasma_applet_ihatethecashew.so
/usr/share/doc/kde-plasma-ihatethecashew-0.4
/usr/share/doc/kde-plasma-ihatethecashew-0.4/COPYING
/usr/share/kde4/services/plasma-applet-ihatethecashew.desktop

# ls -l `rpm -ql kde-plasma-ihatethecashew.i586`
-rwxr-xr-x 1 root root 29056 2009-12-21 00:04 /usr/lib/kde4/plasma_applet_ihatethecashew.so
-rw-r--r-- 1 root root 18273 2009-01-18 11:50 /usr/share/doc/kde-plasma-ihatethecashew-0.4/COPYING
-rw-r--r-- 1 root root   490 2009-12-17 13:20 /usr/share/kde4/services/plasma-applet-ihatethecashew.desktop

/usr/share/doc/kde-plasma-ihatethecashew-0.4:
total 20
-rw-r--r-- 1 root root 18273 2009-01-18 11:50 COPYING

Comment 1 Eli Wapniarski 2009-12-26 17:22:50 UTC
Thanks for the report. I've assigned it. And labeled it works for me for the time being, because it does. This is not say that you don't have an issue. Its just to keep track of whats going on regarding my checks.

Currently I'm running 4.4 Beta on F-12. I will be looking into this the best that I can. I should let you know my progress in a day or 2. Thanks for your patience and sorry about the inconvenience.

Comment 2 Eli Wapniarski 2009-12-26 17:50:33 UTC
Just a quick update. Please understand that I realize that what I'm reporting now is different from the symptoms that you've reported.

I've uninstalled the plasmodid and rebooted the computer. When I logged into my desktop I got little messages all over my desktop that told me that it couldn't open some such plasmoid. I simply right clicked on them and then removed them from my desktop. I then reinstalled the plasmoid with yum install kde-plasma-ihatethecashew and all seemed to be well. I understand that this is different from the problem that you've reported.

If possible
-----------
Could you please try to run the plasmoid using a different user. You could check the root user account, but it would most certainly be better if you could do this with a regular user's account.

It would be a good idea to join the fedora-kde mailing list if you are not a member already. Right now there is a limit to how much I can help because of the fact that I'm running kde 4.4 Betat on F-12.

You can subscribe at

https://admin.fedoraproject.org/mailman/listinfo/fedora-kde

Hopefully we'll get to the bottom of this.

Comment 3 Dave Ulrick 2009-12-26 18:46:29 UTC
Eli,

Like you, my problem started after a reboot.  I saw one message that said something about not being able to open an unnamed plasmoid.  I closed the message.  A bit later I noticed that the cashew was back on the desktop.  Unlike you, however, reinstalling the RPM didn't fix the problem.

I've logged on to a different non-root user and recreated the problem exactly as reported.  I've submitted a request to subscribe to fedora-kde.  I'll email a post about this problem as soon as my subscription is confirmed.

Dave

Comment 4 Rex Dieter 2009-12-26 18:51:58 UTC
I'd venture this latest build was against kde-4.3.4, and the reporter may still have kde-4.3.3.  Can you confirm?

rpm -q kdelibs

Comment 5 Dave Ulrick 2009-12-26 19:04:58 UTC
Here's the version of kdelibs I (the reporter) have on my system:

$ rpm -q kdelibs
kdelibs-4.3.3-4.fc11.i586

Dave

Comment 6 Rex Dieter 2009-12-26 20:40:05 UTC
OK, so easiest resolutions include
1.  wait for kde-4.3.4 to be pushed to stable updates (will likely happen within a few days)
2.  or update to kde-4.3.4 from updates-testing yourself.

Comment 7 Dave Ulrick 2009-12-26 20:47:29 UTC
Good enough!  I'll sit tight until 4.3.4 is pushed out.  I think I can put up with the cashew for a few days.  :-)

Dave

Comment 8 Eli Wapniarski 2009-12-27 06:22:20 UTC
Thanks for the assist Rex.

Dave. Please let me know what happens after you've updated to 4.3.4.

Comment 9 Dave Ulrick 2009-12-29 05:35:02 UTC
I've just finished the update to KDE 4.3.4.  I've successfully added ihatethecashew using Add Widget.  Problem solved!

Comment 10 Eli Wapniarski 2009-12-29 05:55:06 UTC
Great to hear. And thanks for letting me know.


Note You need to log in before you can comment on or make changes to this bug.