Bug 55066 - [pentium pro] Hangs on boot after installing 2.4.9-7smp
[pentium pro] Hangs on boot after installing 2.4.9-7smp
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-24 22:43 EDT by Pete Deffendol
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 12:06:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel-2.4.9-7.i586.rpm boot messages (16.07 KB, text/plain)
2001-10-25 16:31 EDT, Chris Rode
no flags Details
2.4.9-7 i586 /proc/cpuinfo (690 bytes, text/plain)
2001-10-25 16:36 EDT, Chris Rode
no flags Details

  None (edit)
Description Pete Deffendol 2001-10-24 22:43:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
My dual Pentium Pro system hangs at the "Uncompression Linux Kernel...OK" 
message when booting the new 2.4.9-7smp kernel.  The non-SMP 2.4.9 kernel 
boots OK, as does the 2.4.7-10smp kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up and it hangs.
2.
3.
	

Additional info:
Comment 1 Chris Rode 2001-10-25 16:29:52 EDT
Me too.

kernel-smp-2.4.9-7.i686.rpm hangs with:

  Booting command-list

root (hd0,0)
 Filesystem type is ext2fs, partition type 0xfd
kernel /boot/vmlinuz-2.4.9-7smp ro root=/dev/md2 vga=0x0f05
   [Linux-bzImage, setup=0x1400, size=0xfccb2]
initrd /boot/initrd-2.4.9-7smp,img
   [Linux-initrd @ 0x5f7a000, 0x759fe bytes]

Uncompressing Linux... Ok, booting the kernel.
[hang]

Rebuilding the 2.4.9-8 SRPM on the affected machine does not alleviate the 
problem with the i686 optimized SMP kernel.

The following kernels -DO- boot:
kernel-2.4.9-7.i686.rpm
kernel-smp-2.4.9-7.i586.rpm
kernel-2.4.7-10.i686.rpm
kernel-smp-2.4.7-10.i686.rpm

I will attach the boot messages from booting kernel-smp-2.4.9-7.i586.rpm.
Comment 2 Chris Rode 2001-10-25 16:31:42 EDT
Created attachment 35122 [details]
kernel-2.4.9-7.i586.rpm boot messages
Comment 3 Arjan van de Ven 2001-10-25 16:32:56 EDT
Hmmmmm if i586 boots can you please attach the output of 
cat /proc/cpuinfo
?
Comment 4 Chris Rode 2001-10-25 16:36:10 EDT
Created attachment 35123 [details]
2.4.9-7 i586 /proc/cpuinfo
Comment 5 Arjan van de Ven 2001-10-25 16:37:50 EDT
Ok it's not what I thought.
I have a dual ppro machine at work, I'll try to reproduce tomorrow.
Comment 6 Arjan van de Ven 2001-11-04 17:13:41 EST
My dual Pentium Pro works with the 2.4.9-12 / 2.4.9-13 kernels just fine.
Comment 7 Chris Rode 2001-11-04 19:27:37 EST
Still hangs on my dual ppro with 2.4.9-13.i686.  Running kernel-smp-2.4.9-
13.i586 for now.
Comment 8 Pete Deffendol 2001-11-13 00:46:42 EST
kernel 2.4.9-13smp will boot correctly on my machine now.
Comment 9 Chris Rode 2002-01-24 12:06:08 EST
2.4.9-21smp.i686 boots on my machine.  Dunno what the problem was, but it 
appears to be fixed. :)
Comment 10 Arjan van de Ven 2002-01-24 12:12:27 EST
Ok both of you seem to have a working kernel now, so I assume there's no
objection to closing this bug as "fixed in errata".....

Note You need to log in before you can comment on or make changes to this bug.