Bug 55092 - sane-find-scanner find the scanner, but scanimage says: No scanners were identified.
sane-find-scanner find the scanner, but scanimage says: No scanners were iden...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sane-backends (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 10:31 EDT by Matthias Haase
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-26 05:57:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Haase 2001-10-25 10:31:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [de] (X11; U; Linux 2.4.12-SMP-C231001-1 i686)

Description of problem:
After upgrading from RH 7.1 to 7.2 the scsi-scanner (Microtek E6) doesn't
work anymore. This isn't scsi-reladed, or a permissions-error, because the
device is up right. sane-find-scanner view and find the scanner.
The permission of /dev/sg5 is rw for the scanner-group.

After an remove of rpm's sane-backends, sane-frontends and the devel-rpm,
and reinstalling the sane 1.03 rpm from RH 7.1, the scanner does his work
again without any other changes.
 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Switch the scanner on.
2. # /sbin/modprobe tmscsim
3. # /usr/bin/sane-find-scanner -> find the scanner
4. # scanimage -> No scanners were identified.
	

Expected Results:  Easy access to the scanner-device frontends as xsane,
gimp-plugin or xsanimage.

Additional info:
Comment 1 Tim Waugh 2001-10-25 10:34:08 EDT
What model scanner?
Comment 2 Tim Waugh 2001-10-25 10:35:30 EDT
Oh, you said: Microtek E6 (sorry!).
Comment 3 Tim Waugh 2001-10-25 10:43:57 EDT
Please attach the output of 'sane-find-scanner -v' and 'scanimage -L'.  Thanks.
Comment 4 Matthias Haase 2001-10-25 11:11:51 EDT
[root@bennew01 endur]# /usr/bin/sane-find-scanner
# Note that sane-find-scanner will find any scanner that is connected
# to a SCSI bus.  It will even find scanners that are not supported
# at all by SANE. It won't find a scanner that is connected to a
# parallel, USB or other non-SCSI port.

sane-find-scanner: found scanner " Scanner 600 1.90" at device /dev/sg5
sane-find-scanner: found scanner " Scanner 600 1.90" at device /dev/sgf

[root@bennew01 endur]# scanimage
scanimage: no SANE devices found
[root@bennew01 endur]#

As I said, works right again with sane 1.03.
Comment 5 Tim Waugh 2001-10-25 11:22:48 EDT
Please attach the output of 'SANE_DEBUG_MICROTEK=255 scanimage -L'.  Thanks.
Comment 6 Matthias Haase 2001-10-25 11:55:51 EDT
[root@bennew01 endur]# SANE_DEBUG_MICROTEK=255 scanimage -L
[sanei_debug] Setting debug level of microtek to 255.
[microtek] sane_init:  MICROTEK says hello! (v0.12.3)
[microtek] sane_init:  config- # Uncomment following line to disable "real
calibration" routines...[microtek] sane_init:  config- #norealcal[microtek]
sane_init:  config- # Uncomment following line to disable "clever
precalibration" routines...[microtek] sane_init:  config- #noprecal[microtek]
sane_init:  config- #   Using "norealcal" will revert backend to pre-0.11.0
calibration code.[microtek] sane_init:  config- scsi * * Scanner[microtek]
sane_init:  config- /dev/scanner[microtek] attach_scanner:  /dev/scanner
[microtek] attach_scanner:  opening /dev/scanner
[microtek] attach_scanner:  open failed
[microtek] sane_get_devices

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[microtek] sane_exit...
[microtek] sane_exit:  MICROTEK says goodbye.
[root@bennew01 endur]#
Comment 7 Matthias Haase 2001-10-25 11:59:55 EDT
Changing /dev/scanner in /etc/microtek.conf (does not exists) to /dev/sg5 makes
no diff. Exactly same file (/etc/microtek.conf) in sane 1.03
Comment 8 Tim Waugh 2001-10-25 12:03:53 EDT
There should not be a file /etc/microtek.conf; instead there should be a 
/etc/sane.d/microtek.conf.

If you use 'scanimage -d microtek:/dev/sg5', does that work?
Comment 9 Matthias Haase 2001-10-25 12:05:59 EDT
Debug output from sane 1.03

[root@bennew01 endur]# SANE_DEBUG_MICROTEK=255 scanimage -L
[sanei_debug] Setting debug level of microtek to 255.
[microtek] sane_init:  MICROTEK says hello! (v0.12.1)
[microtek] sane_init:  config- # Uncomment following line to disable "real
calibration" routines...[microtek] sane_init:  config- #norealcal[microtek]
sane_init:  config- # Uncomment following line to disable "clever
precalibration" routines...[microtek] sane_init:  config- #noprecal[microtek]
sane_init:  config- #   Using "norealcal" will revert backend to pre-0.11.0
calibration code.[microtek] sane_init:  config- scsi * * Scanner[microtek]
sane_init:  config- /dev/scanner[microtek] attach_scanner:  /dev/scanner
[microtek] attach_scanner:  opening /dev/scanner
[microtek] attach_scanner:  open failed
[microtek] sane_get_devices
[microtek] sane_exit...
[microtek] sane_exit:  MICROTEK says goodbye.
[root@bennew01 endur]# SANE_DEBUG_MICROTEK=255 scanimage -L
[sanei_debug] Setting debug level of microtek to 255.
[microtek] sane_init:  MICROTEK says hello! (v0.12.1)
[microtek] sane_init:  config- # Uncomment following line to disable "real
calibration" routines...[microtek] sane_init:  config- #norealcal[microtek]
sane_init:  config- # Uncomment following line to disable "clever
precalibration" routines...[microtek] sane_init:  config- #noprecal[microtek]
sane_init:  config- #   Using "norealcal" will revert backend to pre-0.11.0
calibration code.[microtek] sane_init:  config- scsi * * Scanner[microtek]
attach_scanner:  /dev/sgf
[microtek] attach_scanner:  opening /dev/sgf
[microtek] attach_scanner:  sending INQUIRY
[microtek] id_microtek...
[microtek] parse_inquiry...
[microtek] parse_inquiry:  E6 falsely denies expanded resolution.
[microtek] parse_inquiry:  E6 falsely denies 1024-byte LUT.
[microtek] dump_inquiry...
 === SANE/Microtek backend v0.12.1 ===
========== Scanner Inquiry Block ========mm
06 31 13 01 5b 16 00 00 20 20 20 20 20 20 20 20 
53 63 61 6e 6e 65 72 20 36 30 30 20 20 20 20 20 
31 2e 39 30 53 43 53 49 20 46 2f 57 56 33 2e 34 
20 43 54 4c 35 33 38 30 03 4f 8c c5 03 ee 66 03 
00 03 01 00 00 03 00 01 0e 0e 01 05 00 00 00 00 
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ff 

========== Scanner Inquiry Report ==========
===== Scanner ID...
Device Type Code: 0x06
Model Code: 0x66
Vendor Name: '        '   Model Name: 'Scanner 600     '
Vendor Specific String: 'SCSI F/WV3.4 CTL5380'
Firmware Rev: '1.90'
SCSI F/W version: 3.1     Scanner F/W version: 1.3
Response data format: 0x01
===== Imaging Capabilities...
Modes:  Lineart Halftone Gray Color (OnePass) 
Resolution Step Sizes: 1% 5%    Expanded Resolution Support? yes(but says no)
Supported Bits Per Sample: 4 8 
Max. document size code: 0x03
Max. document size:  5099 x 7799 pixels
Frame units:  pixels  1/8"'s 
# of built-in halftones: 12   Downloadable patterns? Yes
Data Compression: 
Contrast Settings: 14   Exposure Settings: 14
Adjustable Shadow/Highlight? yes   Adjustable Midtone? yes
Digital brightness/offset? yes
Gamma Table Size: 1024 entries of 1 bytes (max. depth: 8)
===== Source Options...
Feed type:  flatbed    ADF support? yes
Document Feeder Support? yes   Feeder Backtracking? yes
Feeder Installed? no           Feeder Ready? no 
Transparency Adapter Installed? no 
Fast Color Prescan? no
Selectable Transfer Format? no
Color Transfer Sequence: line-by-line, non-sequential with headers
Three pass scan support? yes
ModeSelect-1 and ModeSense-1 Support? yes
Can Disable Linearization Table? no
Can Disable Start-of-Scan Recalibration? yes
Internal expanded expansion? no


[microtek] attach_scanner:  happy.
[microtek] attach_scanner:  /dev/sgf
[microtek] sane_init:  config- /dev/scanner[microtek] attach_scanner: 
/dev/scanner
[microtek] attach_scanner:  opening /dev/scanner
[microtek] attach_scanner:  open failed
[microtek] sane_get_devices
device `microtek:/dev/sgf' is a Microtek ScanMaker E6 flatbed scanner
[microtek] sane_exit...
[microtek] sane_exit:  MICROTEK says goodbye.
[root@bennew01 endur]# 
Comment 10 Matthias Haase 2001-10-25 12:20:45 EDT
Yes, if I use 'scanimage -d microtek:/dev/sg5', this works :-)
The scanner starts up to scan.

Of course, the microtek.conf file is in /etc/sane.d/microtek.conf.
If there I change the path to /dev/sg5 - this works too.

So this is solved, but in sane 1.03, I have not to change microtek.conf.
Comment 11 Tim Waugh 2001-10-25 12:30:08 EDT
The problem seems to be with the device matching in /proc/scsi/scsi.

What does 'cat /proc/scsi/scsi' say?
Comment 12 Matthias Haase 2001-10-25 12:38:44 EDT
# cat /proc/scsi/scsi

Attached devices: 
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: IBM      Model: DPSS-318350N     Rev: S80D
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: IBM      Model: DPSS-318350N     Rev: S80D
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 02 Lun: 00
  Vendor: NEC      Model: CD-ROM DRIVE:466 Rev: 1.26
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 03 Lun: 00
  Vendor: TEAC     Model: CD-R58S          Rev: 1.0M
  Type:   CD-ROM                           ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 04 Lun: 00
  Vendor: iomega   Model: jaz 2GB          Rev: E.17
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 06 Lun: 00
  Vendor:          Model: Scanner 600      Rev: 1.90
  Type:   Scanner                          ANSI SCSI revision: 03

There are two scsi-cards inside: 1. Adaptec 29160N (aic7xxxx statical linked in
the kernel) for UW 160 HD's, 2. Dawicontrol (module tmscsim) for the scanner
only.

Always the same /dev/sg5, this doesn't change, I'm sure about this.

ln -sf /dev/sg5 /dev/scanner solves the problem for me now.

In result, I have not to change always the /ect/sane.d/microtek.conf.

No probs so far.


Comment 13 Tim Waugh 2001-10-25 13:12:39 EDT
I think I can see the problem.  The 'vendor' field that the SCSI device 
returns is blank, and that confuses the matching routine.
Comment 14 Matthias Haase 2001-10-25 13:29:59 EDT
Yes, yes, I think you have found the problem. The scanner is identified on the
bus as an dumb 'Scanner 600' without vendor-information.
This is well known for all Microteks E6. But the matching routine must have
changed in sane 1.05, must be stricter now, not only simple matching the string
'scanner' as before. But this I *think* I'm not sure.


Regards from Germany

Matthias
Comment 15 Tim Waugh 2001-10-26 05:57:48 EDT
A fix for this problem is already committed to CVS, it seems (after 1.0.5 was 
released).

When SANE 1.0.6 is released (quite soon now), it will include this fix.  I'll 
let you know when I have a package built for it.
Comment 16 Tim Waugh 2001-11-08 06:28:57 EST
This is in rawhide now (1.0.6-1).
Comment 17 Matthias Haase 2001-11-08 09:25:30 EST
Thanks for your hint about the new packages in rawhide.
An simple rpm-upgrade fails for me -> missing libgimp-1.2.so.0 -> newer one is
always installed
and missing libusb-01.so.4 -> don't know much about this, we don't using USB on
this server.

Because the machine is an important one, used as file-and print-server in our
company, I could not doing more about this at this time.

Regards from Germany

Matthias
Comment 18 Tim Waugh 2001-11-08 09:31:08 EST
On my Red Hat Linux 7.2 system libgimp-1.2.so.0 is provided by gimp-1.2.1-7, 
and libusb provides libusb-0.1.so.4 (SANE 1.0.6 supports some USB devices and 
does so via libusb).

But you are right not to install Rawhide packages except in a test environment.
Comment 19 Matthias Haase 2001-11-08 14:07:25 EST
I'm not tremulous, if I before the server, the Rawhide packages for sane, I
think, have no much effect about the stability. But for the sane 1.06 I have to
downgrade gimp from 1.2.2 to 1.2.1-7, and in result, I have to recompile xsane
0.80 too. ln -sf /dev/sg5 /dev/scanner solves (as stupid workaround) my problem
very simple.

regards from Germany

                    Matthias

Note You need to log in before you can comment on or make changes to this bug.