This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55103 - evil smelling box characters & nonfunctional KP_ENTER
evil smelling box characters & nonfunctional KP_ENTER
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 12:39 EDT by Mike A. Harris
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-11 04:17:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing box characters. (24.31 KB, image/png)
2001-10-25 20:56 EDT, Mike A. Harris
no flags Details

  None (edit)
Description Mike A. Harris 2001-10-25 12:39:11 EDT
On a fresh xchat startup (blow away ~/.xchat), going to the
without changing anything in setup, go to the channel list
window, click on minimum users, and press keypad enter key
a few times.

The default font unknown box char is displayed and cannot
be removed.  Dunno if this is a GTK bug, or an xchat bug,
but it is uberduber annoying.  ;o)

en_US locale
Comment 1 Mike A. Harris 2001-10-25 12:41:08 EDT
Oops, 7.1 not 7.2.  Using stock xchat, xchat from 7.2, or the new
1.8.4 xchat I built in dist-7.2-gnome
Comment 2 Mike A. Harris 2001-10-25 12:42:59 EDT
Also, this is using XFree86 4.1.0-3

From my XF86Config-4:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "us"
EndSection
Comment 3 Havoc Pennington 2001-10-25 15:17:35 EDT
Works for me with 1.8.4-1

What's xev report as the keysym when you hit KP_Enter?
Comment 4 Mike A. Harris 2001-10-25 20:53:54 EDT
KeyPress event, serial 27, synthetic NO, window 0x1400001,
    root 0x30, subw 0x0, time 3329915882, (948,821), root:(952,844),
    state 0x10, keycode 108 (keysym 0xff8d, KP_Enter), same_screen YES,
"   XLookupString gives 1 characters:  "
 
KeyRelease event, serial 27, synthetic NO, window 0x1400001,
    root 0x30, subw 0x0, time 3329916045, (948,821), root:(952,844),
    state 0x10, keycode 108 (keysym 0xff8d, KP_Enter), same_screen YES,
"   XLookupString gives 1 characters:  "
Comment 5 Mike A. Harris 2001-10-25 20:56:19 EDT
Created attachment 35141 [details]
Screenshot showing box characters.
Comment 6 Mike A. Harris 2001-10-25 20:57:29 EDT
Let me know if u need any more info.

Thanks.
Comment 7 Havoc Pennington 2001-10-26 01:14:51 EDT
I tried on another machine from my normal workstation, doesn't happen. The only
difference is that I have XFree86-4.1.0-1. I have the same XF86Config-4 contents
as you and the same xev output. Basically, I can't reproduce at all.
Comment 8 Mike A. Harris 2002-11-13 03:15:05 EST
This problem is gone now in RHL 8.0, and may have been gone in 7.2 and/or
7.3 as well.

One thing however, is that the keypad ENTER key doesn't work still. xev
shows the key generating events, and it works in other apps, but not
in certain places in xchat.  I can use kp enter in channel dialog,
in various other places, but just not in certain areas of the GUI in
xchat.

I believe this might be a GTK+ issue, but don't know that for sure. Do
either of you know of GTK+ bugs related to KP_ENTER in any widgets?

Comment 9 Mike A. Harris 2003-01-11 04:17:38 EST
The box character problem is definitely gone now.  There seem to be ENTER
problems randomly here and there too, but it is not easy to tell what is
to blame, and this isn't the latest version of everything I'm using currently
so it isn't worth caring about.

Closing bug as fixed in CURRENTRELEASE 8.0.  I'll open new bugs in the future
if there are still problems.

Note You need to log in before you can comment on or make changes to this bug.