Bug 551082 - syntax error at /etc/latexmk.conf line 197, near "$pdf_previewer "
syntax error at /etc/latexmk.conf line 197, near "$pdf_previewer "
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: latexmk (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
:
: 551421 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-28 16:23 EST by terrex
Modified: 2010-01-07 16:49 EST (History)
3 users (show)

See Also:
Fixed In Version: 4.12-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 16:48:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix syntax error (486 bytes, patch)
2009-12-28 16:23 EST, terrex
no flags Details | Diff

  None (edit)
Description terrex 2009-12-28 16:23:59 EST
Created attachment 380679 [details]
Fix syntax error

Description of problem:
latexmk -C
Scalar found where operator expected at /etc/latexmk.conf line 197, near "$pdf_previewer"
	(Missing semicolon on previous line?)
Latexmk: Initialization file '/etc/latexmk.conf' gave an error:
    syntax error at /etc/latexmk.conf line 197, near "$pdf_previewer "
Latexmk: Stopping because of problem with rc file


Version-Release number of selected component (if applicable):
latexmk-4.11-1.fc12.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jerry James 2009-12-29 22:37:20 EST
Thanks for the report.  Yes, that's a missing semicolon all right.  You can edit the file yourself to add it for now.  I'll push a new package ASAP.
Comment 2 Fedora Update System 2009-12-29 23:03:48 EST
latexmk-4.12-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/latexmk-4.12-1.fc12
Comment 3 Fedora Update System 2009-12-29 23:04:02 EST
latexmk-4.12-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/latexmk-4.12-1.fc11
Comment 4 Jerry James 2009-12-30 11:23:14 EST
*** Bug 551421 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2010-01-01 22:28:32 EST
latexmk-4.12-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update latexmk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-0005
Comment 6 Fedora Update System 2010-01-01 22:30:22 EST
latexmk-4.12-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update latexmk'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0014
Comment 7 Fedora Update System 2010-01-07 16:48:48 EST
latexmk-4.12-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2010-01-07 16:49:46 EST
latexmk-4.12-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.