Bug 55115 - man does not obey MANDEFOPTIONS
Summary: man does not obey MANDEFOPTIONS
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-25 19:18 UTC by Need Real Name
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-27 16:23:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-10-25 19:18:57 UTC
Description of Problem:
In the default /etc/man.config that is shipped with man,
there is a comment that MANDEFOPTIONS allows you to
specify default options. We would like to use this to make
man run as man -a by default since that's what our users are
used to from other Unices. However, man does not recognize
this option at all. From looking at the code, I don't
see any mention of it. It would be nice if this could be
implemented. If not, the reference in the man.config file
should at least be removed.


Version-Release number of selected component (if applicable):
man-1.5h1-20

Comment 1 Bernhard Rosenkraenzer 2001-11-27 15:47:36 UTC
Code for handling it is there in 1.5j... Check man_getopt() in man-getopt.c.
Doesn't seem to be working though, debugging.


Comment 2 Bernhard Rosenkraenzer 2001-11-27 16:20:21 UTC
Ok, fixed in 1.5j-1.


Comment 3 Bernhard Rosenkraenzer 2001-11-27 16:23:25 UTC
Sorry, forgot to set the correct resolution. ;)



Note You need to log in before you can comment on or make changes to this bug.