Bug 55130 - Users created in installer unable to log in via ftp.
Users created in installer unable to log in via ftp.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wu-ftpd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-25 19:18 EDT by Jeff Lane
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-25 19:18:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Lane 2001-10-25 19:18:15 EDT
Description of Problem:
On a fresh install of 7.1 onto a machine, a user "admin" was created during
the install process.  After install was complete, edited /etc/ftpaccess as
follows:

changed class line to say:

class	all	real	*

then added the user to the ftp group (usermod -G ftp admin)

The user was unable to log in via ftp from another machine.  The user COULD
log in at the console, and via telnet, and via ssh.

We then created a new user using useradd.  this user, with no modification
at all was able to successfully log in via ftp.  Customer then userdel's
his admin user account, and readded it using useradd, and could now
successfully log in.

In the case where the user could not log in, he got the 503 incorrect
password or username error.

the password used was correct, and to verify this, we changed the password
to password and then tried again, with same effect.  Only by deleting the
user that was created during install, and then recreating the user using
useradd, were we able to successfully get the user logged in via ftp.

Version-Release number of selected component (if applicable):
This was a fresh stock 7.1 install.  wu-ftpd was installed, anonftp  was
NOT installed.

How Reproducible:
So far, should be easily reproduced.  I have spoken with two customers so
far who have had this problem with a fresh 7.1 install.

Steps to Reproduce:
1. Do a format and fresh install of 7.1 
2. Install wu-ftpd but do not install anonft
3. during install, create a dummy user.
4. after install is complete, log in locally as dummy user. 
5. log user out.
6.  attempt to ftp in to that machine as the dummy user.

Actual Results:
User created during install unable to ftp into machine.  User created after
install with useradd command CAN ftp into machine.

Expected Results:
Users should be able to ftp into machine regardless of whether or not the
accounts were created during install or post install.

NOTE:  I have seen no  issues so far with this in cases of upgrade from a
previous version.  I have only seen this issue on new, fresh installs of
7.1 in which users were created during install.
Comment 1 Bernhard Rosenkraenzer 2001-10-30 07:33:49 EST
This is happening not because your admin user was created by the installer, 
but because you added the admin user to the ftp group (which is for anonymous 
ftp only).

wu-ftpd is doing the right thing.

You can see the details of why a login failed in /var/log/messages.


Note You need to log in before you can comment on or make changes to this bug.