Bug 55147 - slovenian keyboard not set after instalation
Summary: slovenian keyboard not set after instalation
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.2
Hardware: athlon
OS: Linux
medium
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-26 11:03 UTC by Simon Golicnik
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 11:19:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Simon Golicnik 2001-10-26 11:03:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
If you select slovenian languge and keyboard in instalation, after reboot 
the LANG is correct bot keyboard is not set to slovenian

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select slovenian keyboard in instalation
2. login and type :(

	

Additional info:

Comment 1 Brent Fox 2001-10-26 13:57:00 UTC
Is this in X or console mode?  

Also, it would be helpful if you could attach your /etc/X11/XF86Config,
/etc/X11/XF86Config-4, and /etc/sysconfig/keyboard files to the bug report.

Comment 2 Simon Golicnik 2001-10-29 06:28:28 UTC
It is in console mode, but can't attach config file because I already manualy 
change this with keyboard config

Comment 3 Brent Fox 2001-10-29 13:30:22 UTC
Ok, I'll try to reproduce this on my test machine.

Comment 4 Brent Fox 2001-11-08 16:29:29 UTC
I've confirmed this bug.  Can you attach your /etc/sysconfig/keyboard and
/etc/X11/XF86Config-4 files so that I can know what the correct settings are?

Comment 5 Simon Golicnik 2001-11-09 11:18:51 UTC
Entry in /etc/sysconfig/keyboard :
------------------------------------------
KEYTABLE="slovene"

Keyboard section in /etc/X11/XF86Config-4:
------------------------------------------
Section "InputDevice"
  Identifier  "Keyboard0"
  Driver      "keyboard"
  Option  "XkbRules"      "xfree86"
  Option  "XkbModel"      "pc105"
  Option  "XkbLayout"     "si"
  Option  "XkbVariant"    "basic"
EndSection


Thanks
Simon

Comment 6 Brent Fox 2001-11-09 21:21:43 UTC
I have committed a fix for this in cvs.  Thanks for your report.



[bfox@bfox anaconda]$ cvs diff kbd.py 
Index: kbd.py
===================================================================
RCS file: /mnt/devel/CVS/anaconda/kbd.py,v
retrieving revision 1.35
diff -u -r1.35 kbd.py
--- kbd.py	2001/09/05 21:26:47	1.35
+++ kbd.py	2001/11/09 21:19:01
@@ -64,6 +64,7 @@
             ("sg"    		 , ('pc102', 'de_CH', '')),
             ("sg-latin1"         , ('pc102', 'de_CH', '')),
             ("sk-qwerty"         , ('pc102', 'us_sk_qwerty', '')),
+            ("slovene"           , ('pc102', 'si', '')),
             ("trq"	         , ('pc102', 'tr', '')),
             ("uk"                , ('pc101', 'gb', '')),
             ("us"                , ('pc105', 'us', '')),


Note You need to log in before you can comment on or make changes to this bug.