Bug 55168 - Grub misreads my disk in lba32 mode
Grub misreads my disk in lba32 mode
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
: 53677 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2001-10-26 11:21 EDT by Thomas Dodd
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-10-18 14:17:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Config files and diagnostics output (4.58 KB, text/plain)
2002-07-12 19:20 EDT, Philip Flip Kromer
no flags Details

  None (edit)
Description Thomas Dodd 2001-10-26 11:21:58 EDT
Description of Problem:
grub won't boot my K6-3 system.
hda is in LARGE mode, not CHS, not LBA.

when booting grub, I see "GRUB"then
notheing. No disk activity, no keyboard response,
no error messages.

Lilo, as setup in anaconda, doesn't work either.
I get "LI" and another freeze. removing the lba32
option from lilo.conf allows lilo to boot the system.

grub has now option to disable lba32 mode.
It needs a way to force lba mode off.

This is an FIC socket7 board. The ATX one
with 2MB L2 cache. (PA-2013 I think)

There has not been a new BIOS rlease since 1999.

How Reproducible:
Grub will not boot this system not once.
SYSLINUX (on a floppy) and lilo will.
Comment 1 Jeremy Katz 2001-11-29 18:36:58 EST
*** Bug 53677 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2002-01-08 16:49:29 EST
Doesn't have a way to turn off LBA32, but it would be interesting to know if the
pcakage at http://people.redhat.com/~katzj/grub/ fixes the problem.  Install the
package and then run `/sbin/grub-install /location/to/install`.  May not do any
better than before, but some bugs in the LBA detection code have been fixed.
Comment 3 Thomas Dodd 2002-01-17 15:39:49 EST
It looked a little better, but still won't boot.
I gathered more info though.
I get:
Grub loading stage 1.5

Grub loading, please wait...
Error 17


I have 2 WDC disks:
/dev/hda (hd0) AC14300R
C/H/S=557/240/63 = 8421840 total

/dev/hdb (hd1) AC24300L
C/H/S=8912/15/63 = 8421840 total

/proc/ide and geometry in the grub shell show
the same info.

Is there a debug mode I can install/build grub with
that might give some more info?
Comment 4 Jeremy Katz 2002-01-27 20:56:48 EST
Interesting... error 17 is an inability to recognize the partition in question.
 What sort of filesystem are you using for /boot?
Comment 5 Thomas Dodd 2002-01-28 10:13:46 EST
ext3, created by Anaconda.
Was adding the second disk to this box,
and did a full install, instead of upgrading
from Seawolf. I tarred /home and
/root to a fat32 partition so every filesystem
is new, ext3 from the start.

Comment 6 Jeremy Katz 2002-02-23 13:16:37 EST
Interestingly enough, someone came to the LUG@NCSU installfest today and had the
same problem...  it turns out that the logical geometry on the disk was
completely wrong.  Reinstalling and doing 'dd if=/dev/zero of=/dev/hda bs=512
count=1' before the installer partitioned the disk fixed the problem.

Then again, may not be the best solution for your case, but as a data point.
Comment 7 Thomas Dodd 2002-07-08 17:17:46 EDT
Somehow I missed you last message. I had gone back to lilo
and forgot to check this bug. Am I on the CC list?

I just installed limbo, and the bug is still there.
I'll try clearing the MBR and reinstall grub.

Anyway to get a version of grub that doesn't try
LBA access at all?

Comment 8 Philip Flip Kromer 2002-07-12 19:20:14 EDT
Created attachment 65190 [details]
Config files and diagnostics output
Comment 9 Philip Flip Kromer 2002-07-12 19:20:36 EDT
I have the same problem as reported in bug 55168: boot fails with 
alone on the screen; the system is unresponsive and must be hard reset.

This is a fresh LIMBO installation to a machine that previously had Windows
XP only. I am using LIMBO on a WD 30GB harddrive in LBA mode.  Kernel is

The primary/master harddrive has a 5G NTFS partition and an extended
partition containing a 25G fat32 partition and a 1G linux swap. The
primary/slave (hdc) has a 5G ext3 partition followed by a 10 G extended
part with a 10G fat32.  The secondary/master has a single 30G fat32
partition. (The output of fdisk -l is attached).

The hard drive parameters, as reported by the manufaturer's diagnostic tool
(Western Digital DataLifeguard), are '59598 cyl, 16 heads, 63 sectors,
30760 MB, 60074784 LBA sectors' -- this differs from that determined by

I have tried asking the BIOS to boot to the primary/master and to the
primary/slave -- same results.

I tried using lilo, which hung at LI_.  This happened with a 'linear' line
in my /etc/lilo.conf, and also with 'lba32' in my /etc/lilo.conf (reran
lilo each time). Lilo complains that
  Warning: BIOS drive 0x82 may not be accessible
This is my swap drive, /dev/hda, located at the end of the primary/master. 

Please see attached files listing all the config info I thought looked

Thanks, flip kromer
Comment 10 Nick Urbanik 2002-10-20 14:57:53 EDT
I too have this problem:
LARGE setting for hda
with lilo, using linear works
When use a grub installation boot disk, made with:
grub-install --root-directory=/mnt/floppy '(fd0)'
grub stage2 can read the hard disk only when switch disk to LBA mode
Need turn off LBA mode in grub.
Comment 11 Nick Urbanik 2002-10-20 14:58:08 EDT
I too have this problem:
LARGE setting for hda
with lilo, using linear works
When use a grub installation boot disk, made with:
grub-install --root-directory=/mnt/floppy '(fd0)'
grub stage2 can read the hard disk only when switch disk to LBA mode
Need turn off LBA mode in grub.
Comment 12 Peter Jones 2005-04-19 14:09:24 EDT
Is this still a problem with current Fedora Core releases?
Comment 13 Thomas Dodd 2005-04-19 14:43:16 EDT
I haven't gotten Fedora installed on that machine.

I've got FC3 CDs to do it, but no time:(

I'll try in a day or two...
Comment 14 Peter Jones 2005-04-19 15:56:59 EDT
OK, just post the results when you know.
Comment 15 Bill Nottingham 2006-10-18 14:17:56 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.