Bug 55194 - syslinux will not accept command line input
syslinux will not accept command line input
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: syslinux (Show other bugs)
7.2
i586 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 16:51 EDT by bobt
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 17:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bobt 2001-10-26 16:51:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Win95; U)

Description of problem:
Anything you type on the linux: prompt is ignored by grub.  Thus I cannot kickstart from the floppy or install in the text mode.
I have a machine with 32MB of ram and it MUST fail out of the install saying not enough memory for a graphic install. I typed
text on the linux: prompt line.  I also will not take input from a network boot floppy with the command  linix text ks=floppy.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot install CD
2.type text on the boot prompt
3.

Actual Results:  on a 32MB machine the install fails from graphic mode because of not enough memory and continues in text mode.

Expected Results:  a text mode install should have occured from the beginning

Additional info:

I have created a network boot disk and added a ks.cfg to the root directory as specified in the documentation.
I type at the boot prompt   linux text ks=floppy
This does not happen and is stopping me from installing 30 boxes with the new 7.2 version of redhat
Comment 1 Jeremy Katz 2001-10-27 01:08:32 EDT
What type of machines are these?  I don't know of any problems with entering
text at the syslinux prompt.

Also, as a workaround, you can edit the syslinux.cfg and change the default to
be ks and add ks=floppy to the ks section (as opposed to just ks)
Comment 2 bobt 2001-10-30 11:58:04 EST
made suggested changes to syslinux.cfg and used command line :   linux ks text
This did try to do a kickstart but it was a network kickstart.
These machines are NEC Powermate V75 machines with 75Mhz processors/ 32Mb of ram/ 540Mb IDE disk.
These machines work just fine under 7.1 with kickstart and such.
Even with the syslinux.cfg file set for ks by default and text mode install the machine would not follow directions
It is missing the /tmp/ks.cfg file. and looking at the log screen it is trying to do a network kickstart.
Comment 3 Jeremy Katz 2001-10-31 17:47:14 EST
You'll also need to change the ks section of the syslinux.cfg to have ks=floppy
in the append section as opposed to just ks.

Reassigning to syslinux for figuring out why input doesn't work.
Comment 4 bobt 2001-11-01 10:40:22 EST
I also did the ks=floppy on the syslinux.cfg file entry.  Still does not work

Comment 5 Matt Wilson 2003-10-09 17:41:57 EDT
I can't reproduce this.

Note You need to log in before you can comment on or make changes to this bug.