Bug 55199 - ImageTTF* functions no longer work
ImageTTF* functions no longer work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-26 20:00 EDT by James Bottomley
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 18:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bottomley 2001-10-26 20:00:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
The problem seems to be caused by the switch from freetype1 to freetype2. 
Any use of ImageTTFText or ImageTTFBBox produces:

<b>Warning</b>:  ImageTtfText: No TTF support in this PHP build in
<b>tabtext.php</b> on line <b>27</b><br>


(This works on RedHat 7.0 and 7.1)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a php program

<?php
		$a = ImageTTFBBox(12, 0, "somefont.ttf", "some text");
?>


2.  run it

	

Actual Results:  X-Powered-By: PHP/4.0.6
Content-type: text/html

<br>
<b>Warning</b>:  ImageTtfBBox: No TTF support in this PHP build in
<b>tmp.txt</b> on line <b>2</b><br>



Expected Results:  exit without error.

Additional info:

I think you need to apply the following two diffs to the php-4.0.6-7
package:

--- php.spec	Fri Oct 26 11:41:24 2001
+++ php.spec~	Mon Aug 27 20:28:05 2001
@@ -211,7 +211,6 @@
 	--with-dom \
 	--with-exec-dir=%{_bindir} \
 	--with-gd \
+	--with-freetype-dir=shared \
 	--with-gdbm \
 	--with-gettext \
 	--with-jpeg-dir=%{_prefix} \
and:

--- ext/gd/gd.c	Fri Oct 26 19:48:45 2001
+++ ext/gd/gd.c~	Mon Jun 11 11:22:10 2001
@@ -2662,7 +2662,7 @@
 	fontname = (unsigned char *) Z_STRVAL_PP(FONTNAME);
 
 #ifdef USE_GD_IMGSTRTTF
+# if HAVE_LIBFREETYPE
-# if HAVE_LIBGD20 & HAVE_LIBFREETYPE
 	error = gdImageStringFT(im, brect, col, fontname, ptsize, angle, x, y,
str);
 # else
 	error = gdImageStringTTF(im, brect, col, fontname, ptsize, angle, x, y,
str);
Comment 1 Phil Copeland 2002-02-07 19:32:51 EST
Try php-4.1.1-2 in rawhide.
if that works ok then I'll see about pushing out an errata

Cherrs

Phil
=--=

Note You need to log in before you can comment on or make changes to this bug.