Bug 55234 - /etc/rc.d/init.d/ypxfrd fails to start
/etc/rc.d/init.d/ypxfrd fails to start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-27 18:44 EDT by Alan Hourihane
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-27 18:44:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Hourihane 2001-10-27 18:44:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.8-26mdk i686)

Description of problem:
ypxfrd fails to start because of an error with the starting
of the rpc program. It's missing the "rpc." in front of the
command. A patch is attached...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. /etc/rc.d/init.d/ypxfrd start
2.
3.
	

Actual Results:  process failed to start

Expected Results:  should have started

Additional info:

Here's patch

--- ypxfrd.old      Tue Aug 28 06:35:51 2001
+++ ypxfrd Sat Oct 27 23:36:45 2001
@@ -20,7 +20,7 @@
 
 start() {
        echo -n $"Starting YP map server: "
-        daemon ypxfrd $YPXFRD_ARGS
+        daemon rpc.ypxfrd $YPXFRD_ARGS
         ETVAL=$?
         echo
         [ $RETVAL -eq 0 ] && touch /var/lock/subsys/ypxfrd
@@ -29,7 +29,7 @@
 
 stop() {
         echo -n $"Stopping YP map server: "
-        killproc ypxfrd
+        killproc rpc.ypxfrd
         RETVAL=$?
         [ $RETVAL -eq 0 ] && rm -f /var/lock/subsys/ypxfrd
         echo
@@ -45,7 +45,7 @@
        stop
        ;;
   status)
-       status ypxfrd
+       status rpc.ypxfrd
        ;;
   restart|reload)
        stop
Comment 1 Florian La Roche 2001-12-08 16:21:35 EST
Fixed in 2.2-2 or higher.

Thanks a lot for this bug-report,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.