Bug 55257 - XFree86 fails to probe video memory
XFree86 fails to probe video memory
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 09:33 EST by Joachim Frieben
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-09 09:25:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree86.0.log XFree86 server log file (deleted)
2001-10-28 09:36 EST, Joachim Frieben
no flags Details
XFree86.0.log XFree86 server log file (deleted)
2001-10-28 09:36 EST, Joachim Frieben
no flags Details
XFree86.0.log XFree86 server log file (deleted)
2001-10-28 10:01 EST, Joachim Frieben
no flags Details | Diff
XFree86.0.log XFree86 server log file (deleted)
2001-10-28 10:04 EST, Joachim Frieben
no flags Details
XFree86.0.log X server log file (deleted)
2001-10-29 14:28 EST, Joachim Frieben
no flags Details
XFree86.0.log XFree86 X server log file (deleted)
2001-10-29 15:03 EST, Joachim Frieben
no flags Details
XFree86.0.log XFree86 server log file (21.36 KB, text/plain)
2001-10-30 04:54 EST, Joachim Frieben
no flags Details
XF86Config-4 XFree86 server config file (3.65 KB, text/plain)
2001-10-30 04:55 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2001-10-28 09:33:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
XFree86* fails to probe the amount of available video memory of a Matrox
Millennium II PCI 8MB graphics card. However, at install time, 'anaconda'
correctly reported 8192KB as the available memory amount, but already when
testing the chosen video mode of 1400x1050 at 24bpp, a lower resolution of
1152x864 was displayed instead. It was necessary to checkmark 16 bpp
(instead of 24bpp) in order to obtain the requested resolution of
1400x1050. According to XFree86.0.log, XFree86* is unable to probe the
amount of video memory because of a hardware bug (see attached
'XFree86.0.log' file) which is in contradiction with 'anaconda's' correct
determination of the memory amount. The main board is a Dual Pentium Pro
INTEL PR440FX.

Version-Release number of selected component (if applicable):
4.1.0-3

How reproducible:
Always

Steps to Reproduce:
1. Start X.
2. Browse XFree86.0.log


Actual Results:  XFree86* only uses 4096KB of video memory whereas the card
is equipped with 8192KB.

Expected Results:  XFree86* should successfully probe the amount of video
memory to be 8192KB and use the total memory.

Additional info:

Adding the line 'VideoRam 8192' in XF86Config-4 by hand in order to
override the autosensing cures the problem.
Comment 1 Mike A. Harris 2001-10-28 15:07:30 EST
There are 4 attachments, but none of them are valid log files.  They
appear to be blank HTML documents.  I'm not sure how you're trying
to attach these, but it is not working.  Simply click on the create
a file attachment link below, click on the "browse" button, locate
the files on your hard drive, and select them.  Be sure to set the
MIME type to text/plain so it is visible when someone clicks on it.

Also include your config file.  Thanks.
Comment 2 Joachim Frieben 2001-10-30 04:54:51 EST
Created attachment 35643 [details]
XFree86.0.log XFree86 server log file
Comment 3 Joachim Frieben 2001-10-30 04:55:48 EST
Created attachment 35644 [details]
XF86Config-4 XFree86 server config file
Comment 4 Mike A. Harris 2002-02-09 09:24:58 EST
Dave, this bug report is weird, because there are 8 file attachments
showing in the attachment list and only 2 showing in the comment area.
Must be a bug in the bugzilla code or missing data in the database
perhaps.
Comment 5 Mike A. Harris 2002-02-09 09:32:08 EST
(WW) MGA(0): Unable to probe memory amount due to hardware bug.  Assuming 4096 KB
(--) MGA(0): VideoRAM: 4096 kByte

The above is correct.  If anaconda is defaulting to 8Mb of
RAM for this card, then anaconda has a hard coded 8Mb for this card's
PCI ID in it somewhere, and any 4Mb cards will get misconfigured by
anaconda as an 8Mb card.  In either case, anaconda should not ever force
the memory amount without allowing the user to manually select the amount
of RAM.  The only way to have the RAM set properly for this card, is to
set the RAM amount manually for it.

So, the bug lay not in XFree86, but in the video card itself, and also in
anaconda for wrongly forcing 8Mb, and giving the illusion it detected 8Mb.

I've updated the hardware database I believe to fix this problem.

Comment 6 Mike A. Harris 2002-02-09 09:32:47 EST
Ooops, I forgot to mention.  To configure your card, run:

Xconfigurator

and manually set the memory to 8Mb.

Note You need to log in before you can comment on or make changes to this bug.