Bug 55270 - (IDE, PROMISE)installer kernel doesn't work with Promise IDE controller
(IDE, PROMISE)installer kernel doesn't work with Promise IDE controller
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 18:48 EST by Tom Cross
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 22:24:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Cross 2001-10-28 18:48:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.5) Gecko/20011013

Description of problem:
My system has Promise IDE controller that works fine with rh7.1 (2.4.3-12).
 When booting installer, I have to tell the use "linux ide0=0xb400" to get
it to see the promise controller as ide0.  When I do this, the kernel hangs
at the "Partition check:" with "hda:" only being displayed.  The upgraded
2.4.9-6 kernel for rh7.1 does the same thing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot rh7.2 2.4.7 kernel or rh7.1 2.4.9-6 kernel
2.
3.
	

Actual Results:  kernel halts at the partition check phase when I give it
the "ide0=0xb400" kernel parameter.


Expected Results:  Here is a dmesg log from rh7.1 boot with 2.4.3-12 kernel:

Linux version 2.4.3-12 (root@porky.devel.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.1 2.96-85)) #1 Fri Jun 8 16:12:46 EDT 2001
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009e800 (usable)
 BIOS-e820: 000000000009e800 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000000bffc000 (usable)
 BIOS-e820: 000000000bffc000 - 000000000bfff000 (ACPI data)
 BIOS-e820: 000000000bfff000 - 000000000c000000 (ACPI NVS)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
On node 0 totalpages: 49148
zone(0): 4096 pages.
zone(1): 45052 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=2.4.3-12 ro root=306
BOOT_FILE=/boot/vmlinuz-2.4.3-12
Initializing CPU#0
Detected 350.809 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 699.59 BogoMIPS
Memory: 189500k/196592k available (1233k kernel code, 5168k reserved, 93k
data, 236k init, 0k highmem)
Dentry-cache hash table entries: 32768 (order: 6, 262144 bytes)
Buffer-cache hash table entries: 8192 (order: 3, 32768 bytes)
Page-cache hash table entries: 65536 (order: 7, 524288 bytes)
Inode-cache hash table entries: 16384 (order: 5, 131072 bytes)
VFS: Diskquotas version dquot_6.5.0 initialized
CPU: Before vendor init, caps: 008021bf 808029bf 00000000, vendor = 2
CPU: L1 I Cache: 32K (32 bytes/line), D cache 32K (32 bytes/line)
CPU: After vendor init, caps: 008021bf 808029bf 00000000 00000002
CPU:     After generic, caps: 008021bf 808029bf 00000000 00000002
CPU:             Common caps: 008021bf 808029bf 00000000 00000002
CPU: AMD-K6(tm) 3D processor stepping 0c
Checking 'hlt' instruction... OK.
POSIX conformance testing by UNIFIX
mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)
mtrr: detected mtrr type: AMD K6
PCI: PCI BIOS revision 2.10 entry at 0xf0560, last bus=1
PCI: Using configuration type 1
PCI: Probing PCI hardware
PCI: Using IRQ router ALI [10b9/1533] at 00:07.0
isapnp: Scanning for PnP cards...
isapnp: Calling quirk for 01:00
isapnp: SB audio device quirk - increasing port range
isapnp: Card'Creative ViBRA16X PnP'
isapnp: 1 Plug & Play card detected total
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.14)
Starting kswapd v1.8
pty: 512 Unix98 ptys configured
block: queued sectors max/low 125677kB/41892kB, 384 slots per queue
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
Uniform Multi-Platform E-IDE driver Revision: 6.31
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
PDC20262: IDE controller on PCI bus 00 dev 58
PCI: Found IRQ 7 for device 00:0b.0
PDC20262: chipset revision 1
PDC20262: not 100% native mode: will probe irqs later
PDC20262: (U)DMA Burst Bit ENABLED Primary PCI Mode Secondary PCI Mode.
    ide0: BM-DMA at 0xa000-0xa007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xa008-0xa00f, BIOS settings: hdc:DMA, hdd:pio
ALI15X3: IDE controller on PCI bus 00 dev 78
PCI: No IRQ known for interrupt pin A of device 00:0f.0. Please try using
pci=biosirq.
ALI15X3: chipset revision 193
ALI15X3: not 100% native mode: will probe irqs later
    ide2: BM-DMA at 0x9800-0x9807, BIOS settings: hde:pio, hdf:pio
    ide3: BM-DMA at 0x9808-0x980f, BIOS settings: hdg:pio, hdh:pio
hda: Maxtor 54098U8, ATA DISK drive
hdg: BCD-44XH CD-ROM, ATAPI CD/DVD-ROM drive
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide0 at 0xb400-0xb407,0xb002 on irq 7
ide3 at 0x170-0x177,0x376 on irq 15
hda: 80041248 sectors (40981 MB) w/2048KiB Cache, CHS=79406/16/63, UDMA(66)
Partition check:
 hda: [PTBL] [4982/255/63] hda1 hda2 hda3 < hda5 hda6 >


Additional info:

I think this only happens when I give the kernel the ide0=0xb400 parameter,
but since my system is setup to boot from /dev/hda (lilo, fstab, etc) it's
hard to test without it.

The 2.4.3-12 kernel from rh7.1 sees the Promise IDE controller as ide0
automatically without any additional parameters or forcing.

Note You need to log in before you can comment on or make changes to this bug.