Bug 55273 - mc hangs after executing commands on console (ls for example)
mc hangs after executing commands on console (ls for example)
Status: CLOSED DUPLICATE of bug 51833
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 20:01 EST by Dominik Mierzejewski
Modified: 2013-04-02 00:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-10 20:43:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik Mierzejewski 2001-10-28 20:01:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.12 i686)

Description of problem:
When I run mc as ordinary user on the console, mc always hangs
either at once or after running some command - i.e. I type ls
and presto! it hangs. This doesn't happen if I run it as root
or from gnome-terminal.
strace reveals it hangs on reading fd 7 (this is after doing `ls'):
[...]
read(4, "-rw-r--r--    1 dominik  users  "..., 100) = 83
write(1, "-rw-r--r--    1 dominik  users  "..., 83) = 83
select(1024, [0 4 8], NULL, NULL, NULL) = 1 (in [4])
read(4, "\33[m", 100)                   = 3
write(1, "\33[m", 3)                    = 3
select(1024, [0 4 8], NULL, NULL, NULL) = 1 (in [8])
--- SIGCHLD (Child exited) ---
wait4(4005, [WIFSTOPPED(s) && WSTOPSIG(s) == SIGSTOP], WNOHANG|WUNTRACED,
NULL) = 4005
wait4(4033, 0xbffff3c4, WNOHANG|WUNTRACED, NULL) = 0
sigreturn()                             = ? (mask now [])
read(8, "/home/dominik\n", 4096)        = 14
rt_sigprocmask(SIG_BLOCK, [CHLD], [], 8) = 0
kill(4005, SIGCONT)                     = 0
rt_sigprocmask(SIG_SETMASK, [], NULL, 8) = 0
kill(4033, SIGCONT)                     = 0
write(6, "3", 1)                        = 1
read(7, 0x80c2630, 1)                   = ? ERESTARTSYS (To be restarted)
--- SIGCHLD (Child exited) ---
wait4(4005, 0xbffff49c, WNOHANG|WUNTRACED, NULL) = 0
wait4(4033, [WIFEXITED(s) && WEXITSTATUS(s) == 0], WNOHANG|WUNTRACED, NULL)
= 4033
kill(4033, SIGCONT)                     = -1 ESRCH (No such process)
close(6)                                = 0
close(7)                                = 0
pipe([5, 6])                            = 0
pipe([7, 10])                           = 0
fork()                                  = 4038
close(5)                                = 0
close(10)                               = 0
read(7, "\2", 1)                        = 1
sigreturn()                             = ? (mask now [])
read(7, 
and then it just sits here.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. log in on a standard virtual console as ordinary user
2. run mc
3a. sometimes it hangs here
3b. if not, type any external command, for example `ls'
4. it hangs

	

Actual Results:  mc hangs

Expected Results:  it shouldn't hang, now should it?

Additional info:

All errata applied.
mc-4.5.51-36
kernel-2.4.9-7 and my home-made 2.4.12 - same results
Comment 1 Konstantin 2001-10-30 13:03:21 EST



This also happens when just switching from panels to console.
This also happens with mc taken from previous versions 4.5.51-32 (from RedHat 7.1) and 4.5.51-18 (from RedHat 7.0), when installed on RedHat 7.2
So it seems to be not the mc's bug.
Comment 2 Aaron Brown 2001-10-30 14:45:52 EST
I'm not able to reproduce this on 2.4.9-7 or 2.4.9-7smp on i686.
Also, it works fine on Athlon 2.4.9-10 and 2.4.9-10smp.
I tried it as root and as a regular user, with and without X.

Can you reproduce this on another system?

I did note that I'm using 4.5.54, which is what you should have if you 
have all errata applied, but I had no problem with 4.5.51 and .51-36.

Comment 3 Dominik Mierzejewski 2001-10-30 19:28:04 EST
I have no other RH7.2 Linux box so I can't try it on another system.
And I do have all errata applied - up2date doesn't show mc-4.5.54.
But - as checat@chat.ru noticed - this is either not mc bug or a bug
triggered by something new in RH 7.2. Either way - we need to find
out what's changed that mc uses or depends on.
Comment 4 Need Real Name 2001-11-01 08:01:41 EST
mc wait for data from cons.saver and cons.saver wait for data from mc...

[root@w-vsmj1 root]# strace -p 1109
read(7,  <unfinished ...>
[root@w-vsmj1 root]# lsof | grep 1311
mc        1109 mjezek    7r  FIFO        0,0             1311 pipe
cons.save 1140 mjezek    1w  FIFO        0,0             1311 pipe
[root@w-vsmj1 root]# strace -p 1140
read(0,  <unfinished ...>
[root@w-vsmj1 root]# lsof | grep 1310
mc        1109 mjezek    6w  FIFO        0,0             1310 pipe
cons.save 1140 mjezek    0r  FIFO        0,0             1310 pipe

When I remove cons.saver it works OK
Comment 5 CoreDump 2001-11-02 19:15:31 EST
This appears to be the same bug as #51833. (happened on 4.5.51)
Try to install mc-4.5.55 from www.gnome.org/mc
It works for me.
Comment 6 Need Real Name 2001-11-09 03:52:39 EST
The Bug is still there. Why it is marked as assigned ?? I can reproduce the 
bug on 3 system - RH7.2 with all updates installed. If i start mc and press 
serveral time ctrl-o, mc hangs... 
Comment 7 Konstantin 2001-11-10 07:01:34 EST
Have another friend's confirmation on this bug.
Removing of the cons.saver really helps, but then switching to panels will 
clear program output. mc-4.5.55 compiled "by default" creates it's own 
cons.saver, but doesn't use it too. (It doesn't exist in `ps` output.)
Comment 8 Dominik Mierzejewski 2001-11-10 20:43:01 EST
I've just compiled and installed mc-4.5.55. The bug is no longer there. So, for
anyone interested I'm putting my home-made rpm package at
http://rhcontrib.bero.org. Unfortunately, checat@chat.ru is right -
console.saver is gone and command output is lost after ^O.
Comment 9 Dominik Mierzejewski 2001-11-10 20:56:50 EST

*** This bug has been marked as a duplicate of 51833 ***

Note You need to log in before you can comment on or make changes to this bug.