Bug 55274 - Nvidia driver compile against 2.4.9-7 kernel
Nvidia driver compile against 2.4.9-7 kernel
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 20:59 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-21 10:37:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-28 20:59:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
I cannot compile the Nvidia 1.0-1541 driver against the newly released
2.4.9-7 kernel, I get unresolved symbol errors. GLX compiles just fine. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.untar the NVidia kernel and GLX files	
2.cd NVidia_kernel directory
3.run make
	

Actual Results:  Driver started to compile, then came the unresolved symbol
errors, and exited with error 255.

Expected Results:  The driver should have built.

Additional info:

I am running a AMD T-bird 1200 on a Abit KT7A-raid mb, using a GeForce 2MX
chipset, 32 mb. I got the kernel 2.4.9-7 from the Redhat Network,
downloaded with the up2date application.
Comment 1 Arjan van de Ven 2001-10-29 03:57:14 EST
1) This is a bug that should be sent to nvidia as it's their proprietary driver
   that doesn't work
2) can you check /boot/kernel.h to see if that says "i686" somewhere? If it does
   please change it to athlon and rebuild the nvidia driver....

Note You need to log in before you can comment on or make changes to this bug.