Bug 55276 - panel crashed at start with
panel crashed at start with
Status: CLOSED DUPLICATE of bug 55119
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-28 23:35 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-08 18:53:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-28 23:35:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
For users with Gnome sawfish default desktop, after upgrade of 7.1 to
enigma 7.2 all panels crashed and disapeared after logging that user in,
except for root.Log in is command line and not graphical.

Ther error message was:

Application "panel" (process 1341) has crashed due to fatal error.
(Segmentation fault)

Logging back in or rebooting does not replace the lost panels. There is no
way to access any panel, all are gone.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to 7.2
2.Log in as existing user
3.run startx
	

Actual Results:  I got error on initial start of Gnome sawfish and no panel
even with reboot.

Additional info:

Root was not affected although it was basicaly the same, but it used a
different theme so I would be always aware I was on as root.
Comment 1 Havoc Pennington 2001-10-29 10:42:13 EST
What theme were you using?

If you "submit bug report" in the crash dialog, it should show you a backtrace; 
can you reproduce the bug enough to provide that? just cut-and-paste the
backtrace here, no need to actually submit the report again.
Comment 2 Need Real Name 2001-10-29 16:07:21 EST
Sorry, I clicked on the link and not the generate bug report button in the error
message. I have since deleted and recreated all the users and they seem to work
OK now. It seemed to be related to accepting letting the setup change my default
settings the first time I started up with a given user. My sawfish settings were
Blue and Gray and Crux themes. I was already using those with all but root,
although the new Crux is different from the old Crux theme with the close
application button on the left instead of the right on the top of the window.
Root also crashed once but the panel was restored the next time I logged on as
root.
Comment 3 Need Real Name 2001-10-29 21:51:54 EST
It happened again with a new user and I sent a report by clicking on the button
instead of the link. I hope this helps, see also:

http://bugzilla.gnome.org/show_bug.cgi?id=63352
Comment 4 Havoc Pennington 2001-10-29 22:42:47 EST
Possible dup of 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=55119
Comment 5 Geo. Anderson 2001-11-09 08:13:40 EST
I am seeing a pair of bugs; installation is the shrink-wrap 7.2 on a Compaq M700
laptop.

Sometimes Panel crashes with a segmentation fault (apparently Gnome tries
endlessly to restart it, so there is endless opportunity to ack the error
message).  In this case, Nautilus runs o.k.  More often, now, Panel starts o.k.
but Nautilus produces the segmentation fault.  In the latter case, there are
also no icons displayed on the desktop but everything else seems to be o.k.

I am a newbie, have played a bit with 7.1.  My goal is to replace our Neware
servers with linux servers but for now I am in the early exploration phase. 
Thus can't give much technical info beyond the screen messages.
Comment 6 Pete Chown 2001-11-16 04:31:15 EST
I seemed to be getting the same problem as George on my desktop.  I think I've
fixed it but it's hard to be sure because it was always intermittent.  A few
days ago I downloaded the latest Linus kernel, added the ext3 patch and
recompiled.  Since then the problem hasn't occurred.

It always looked as though the buffer cache was getting corrupted somehow,
because while it was usually the panel that gave trouble, sometimes it would be
other programs.  Once a program had started misbehaving it would continue to do
so, as though the copy which was in memory differed from that on the disk. 
Sometimes the problem was so obvious that by no stretch of the imagination could
it be a problem with the program itself.  For example occasionally a program
wouldn't even display the "ldd" list.  Reinstalling the RPM would fix the
problem until the next boot, presumably because the in-memory copy was refreshed
from the CD.

Interestingly I ran the 2.4.9 kernel on the same machine when it first came out,
and I didn't get that problem then.  I wonder if it is a RedHat-specific patch
or a particular build option which was causing the trouble.
Comment 7 Havoc Pennington 2002-02-08 18:52:56 EST
See http://bugzilla.gnome.org/show_bug.cgi?id=69333
Comment 8 Havoc Pennington 2002-02-25 19:49:45 EST

*** This bug has been marked as a duplicate of 55119 ***

Note You need to log in before you can comment on or make changes to this bug.