Bug 552846 - use GMP
use GMP
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 05:47 EST by Pádraig Brady
Modified: 2010-01-26 06:51 EST (History)
3 users (show)

See Also:
Fixed In Version: coreutils-7.2-7.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-26 06:51:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pádraig Brady 2010-01-06 05:47:26 EST
All coreutils >= 7.0 should depend on gmp-devel + gmp
Otherwise coreutils will not support large numbers in contradiction to the docs

For example you get the following on F11:

$ expr 4951760154835678088235319297 + 0
expr: 4951760154835678088235319297: Numerical result out of range
Comment 1 Ondrej Vasik 2010-01-06 06:01:48 EST
Thanks for report, Pádraig. Will fix that soon.
Comment 2 Ondrej Vasik 2010-01-12 11:58:40 EST
Strange, fedora update system seems to be broken somehow. So just manually... update submitted to testing - koji build: http://koji.fedoraproject.org/koji/buildinfo?buildID=150619
Comment 3 Ondrej Vasik 2010-01-26 06:51:21 EST
Fixed in coreutils-7.2-7.fc11 which is already in stable ... wonder why it was not closed automatically by fedora updates system. Closing.

Note You need to log in before you can comment on or make changes to this bug.