Bug 552848 - After an update I've lost my eclipse workspace
After an update I've lost my eclipse workspace
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 05:50 EST by Paulo Fidalgo
Modified: 2010-01-07 17:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-07 09:22:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paulo Fidalgo 2010-01-06 05:50:53 EST
Description of problem:

After this update yesterday:

Jan 05 23:04:47 Updated: libtar-1.2.11-16.fc12.x86_64
Jan 05 23:04:49 Updated: 1:eclipse-swt-3.5.1-21.fc12.x86_64
Jan 05 23:04:54 Updated: 1:eclipse-rcp-3.5.1-21.fc12.x86_64
Jan 05 23:05:18 Updated: 1:eclipse-platform-3.5.1-21.fc12.x86_64
Jan 05 23:05:20 Updated: psacct-6.3.2-59.fc12.x86_64
Jan 05 23:05:25 Updated: 2:shadow-utils-4.1.4.2-2.fc12.x86_64
Jan 05 23:05:28 Updated: gdb-7.0.1-19.fc12.x86_64
Jan 05 23:05:41 Updated: texlive-texmf-2007-34.fc12.noarch
Jan 05 23:05:45 Updated: texlive-texmf-dvips-2007-34.fc12.noarch
Jan 05 23:06:01 Installed: texlive-texmf-latex-2007-34.fc12.noarch
Jan 05 23:06:03 Updated: texlive-texmf-xetex-2007-34.fc12.noarch
Jan 05 23:06:10 Updated: texlive-texmf-context-2007-34.fc12.noarch
Jan 05 23:06:15 Updated: 1:eclipse-jdt-3.5.1-21.fc12.x86_64
Jan 05 23:06:57 Updated: texlive-texmf-fonts-2007-34.fc12.noarch
Jan 05 23:06:59 Updated: system-config-lvm-1.1.11-1.fc12.noarch
Jan 05 23:07:16 Erased: tetex-perltex


After starting eclipse, I've lost my worksapce. No projects are list, although they are on the disk.

If I start with the -consolelog swicth I have this message:

eclipse -consolelog
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
!SESSION 2010-01-06 10:25:15.365 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -consolelog

!ENTRY org.eclipse.equinox.p2.repository 4 0 2010-01-06 10:25:18.389
!MESSAGE ProvisioningEventBus could not be obtained. Metadata caches may not be cleaned up properly.

(.:3385): GLib-WARNING **: g_set_prgname() called multiple times


The message apears before I select the location of the workspace.
If I remove .eclipse dir in my $HOME, the problem remains.

I think the only solution so far is to create a new workspace and import the projects from the old location.


Version-Release number of selected component (if applicable):

eclipse-platform.x86_64 1:3.5.1-21.fc12


Additional info:

This have happened befora, but at that time I haven't report, I've only created an new workspace and import the projects.
Comment 1 Paulo Fidalgo 2010-01-06 05:57:57 EST
After a reinstall of 

in the startup I've got this message:

eclipse -consolelog
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles
!SESSION 2010-01-06 10:54:44.635 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -consolelog

!ENTRY org.eclipse.equinox.p2.repository 4 0 2010-01-06 10:54:45.608
!MESSAGE ProvisioningEventBus could not be obtained. Metadata caches may not be cleaned up properly.

!ENTRY org.eclipse.equinox.p2.directorywatcher 4 0 2010-01-06 10:54:47.195
!MESSAGE The installable unit org.eclipse.jdt.compiler.apt.translated_host_properties is missing the filename property.

!ENTRY org.eclipse.equinox.p2.directorywatcher 4 0 2010-01-06 10:54:47.196
!MESSAGE The installable unit org.eclipse.jdt.compiler.tool.translated_host_properties is missing the filename property.

!ENTRY org.eclipse.equinox.p2.directorywatcher 4 0 2010-01-06 10:54:47.277
!MESSAGE The installable unit org.eclipse.jdt.compiler.apt.translated_host_properties is missing the filename property.

!ENTRY org.eclipse.equinox.p2.directorywatcher 4 0 2010-01-06 10:54:47.277
!MESSAGE The installable unit org.eclipse.jdt.compiler.tool.translated_host_properties is missing the filename property.

(.:4363): GLib-WARNING **: g_set_prgname() called multiple times

From this page: http://fedoraproject.org/wiki/DebuggingEclipseProblems

[fidalgo@bastard eclipse]$ for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done
[fidalgo@bastard eclipse]$ which java
/usr/bin/java
[fidalgo@bastard eclipse]$ readlink -f `which java`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
[fidalgo@bastard eclipse]$ which javac
/usr/bin/javac
[fidalgo@bastard eclipse]$ readlink -f `which javac`
/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/bin/javac
[fidalgo@bastard eclipse]$ java -version
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.6) (fedora-33.b16.fc12-x86_64)
OpenJDK 64-Bit Server VM (build 14.0-b16, mixed mode)
Comment 2 Paulo Fidalgo 2010-01-06 06:09:54 EST
Sorry for SPAM, but I can't change my old posts.

I've found this:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=275059

Aparently this have been solved in a version after 3.5.2, but with a major rewrite, wich I don't know if has already been released.
Comment 3 Andrew Overholt 2010-01-06 08:41:42 EST
So Eclipse starts up but none of your projects are listed?  Can you try forcing the workspace location with the -data switch and see if that helps?  I updated myself yesterday and have had no problems.  Please try running with -consolelog -debug and attach the output here.  Thanks.
Comment 4 Paulo Fidalgo 2010-01-06 09:17:12 EST
eclipse -data /mnt/disk/workspace.old/ -consolelog -debug
Start VM: /usr/bin/java                                                       
-Xms128m                                                                      
-Xmx1024m                                                                     
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding                   
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile    
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles       
-XX:MaxPermSize=256m                                                                                              
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar                          
-os linux                                                                                                         
-ws gtk                                                                                                           
-arch x86_64                                                                                                      
-showsplash                                                                                                       
-launcher /usr/lib64/eclipse/eclipse                                                                              
-name Eclipse                                                                                                     
--launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.200.v20090519/eclipse_1207.so                                                                                                              
-startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar                          
-exitdata 1f0003                                                                                                      
-data /mnt/disk/workspace.old/                                                                                        
-consolelog                                                                                                           
-debug                                                                                                                
-vm /usr/bin/java                                                                                                     
-vmargs                                                                                                               
-Xms128m                                                                                                              
-Xmx1024m                                                                                                             
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins                                      
-XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith                              
-XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init>                 
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate    
-XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding                       
-XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile        
-XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles           
-XX:MaxPermSize=256m                                                                                                  
-jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar                              
CompilerOracle: exclude org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith                                 
CompilerOracle: exclude org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding.<init>                    
CompilerOracle: exclude org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates.instantiateTemplate       
CompilerOracle: exclude org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage.addBinding                          
CompilerOracle: exclude org/python/pydev/editor/codecompletion/revisited/PythonPathHelper.isValidSourceFile           
CompilerOracle: exclude org/python/pydev/ui/filetypes/FileTypesPreferencesPage.getDottedValidSourceFiles              
Install location:                                                                                                     
    file:/usr/lib64/eclipse/                                                                                          
Configuration file:                                                                                                   
    file:/usr/lib64/eclipse/configuration/config.ini loaded                                                           
Configuration location:                                                                                               
    file:/home/fidalgo/.eclipse/793567567/configuration/                                                              
Configuration file:                                                                                                   
    file:/home/fidalgo/.eclipse/793567567/configuration/config.ini loaded
Shared configuration location:
    file:/usr/lib64/eclipse/configuration/
Framework located:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.5.1.R35x_v20090827.jar
Framework classpath:
    file:/usr/lib64/eclipse/plugins/org.eclipse.osgi_3.5.1.R35x_v20090827.jar
Splash location:
    /usr/lib64/eclipse/plugins/org.eclipse.platform_3.3.201.R35x_v20090813/splash.bmp
Debug options:
    file:/home/fidalgo/.options not found
Time to load bundles: 5
!SESSION 2010-01-06 14:12:52.828 -----------------------------------------------
eclipse.buildId=M20090917-0800
java.version=1.6.0_0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86_64 -data /mnt/disk/workspace.old/ -consolelog -debug

!ENTRY org.eclipse.equinox.p2.repository 4 0 2010-01-06 14:12:53.869
!MESSAGE ProvisioningEventBus could not be obtained. Metadata caches may not be cleaned up properly.
Starting application: 1101

(.:7005): GLib-WARNING **: g_set_prgname() called multiple times
Application Started: 6249


It's a very odd behaviour, because if I create another workspace, and import the projects it works like a charm. Although it never works for the "damaged" workspace.
Comment 5 Andrew Overholt 2010-01-06 11:32:11 EST
I don't know what could have caused this.  There are no errors reported so it's very difficult to diagnose.  What sort of filesystem are you using for your workspace?  Are the project symlinks, perhaps?  Really I'm just guessing at this point ...
Comment 6 Paulo Fidalgo 2010-01-07 05:03:05 EST
I'm using ext4, but since I can read the new created workspace this should not be an eclipse bug at all and it's not happening to anyone else.
So it's safe to mark this bug with invalid.

Thanks for your time.
Comment 7 Andrew Overholt 2010-01-07 09:22:23 EST
Thanks for the report.  If we can figure out what caused it, I'll be happy to debug.
Comment 8 Paulo Fidalgo 2010-01-07 17:04:43 EST
I've figured out why this happens, when my pc suspends, in the shutdown I have an abnormal shutdown, because the system hangs, and the caps lock light blinks.
This should be cause by SeLinux preventing vbetool unsafe memory operations.

Note You need to log in before you can comment on or make changes to this bug.