Bug 552919 - [abrt] crash in qemu-system-x86-2:0.12.1.2-2.fc13
[abrt] crash in qemu-system-x86-2:0.12.1.2-2.fc13
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
abrt_hash:81ef1c3575191aaa7941706f4dc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 09:38 EST by Tom London
Modified: 2010-02-10 09:58 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-10 09:58:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (12.12 KB, text/plain)
2010-01-06 09:38 EST, Tom London
no flags Details

  None (edit)
Description Tom London 2010-01-06 09:38:40 EST
abrt 1.0.2 detected a crash.

How to reproduce
-----
1. install 2:qemu-kvm-0.12.1.2-2.fc13.x86_64 (and friends)
2. run 'qemu-kvm -localtime -vga std -m 1024 -usbdevice tablet -name "Windows 7" -soundhw es1370 -hda ~/VirtualMachines/Win7.img'
3.

Comment
-----
Just installed Rawhide update (2:qemu*-0.12.1.2-2.fc13.x86_64) and tried to start VM via 'qemu-kvm'.

I believe this is an "abrt generated" dup of https://bugzilla.redhat.com/show_bug.cgi?id=552639.

Attached file: backtrace
cmdline: qemu-kvm -localtime -vga std -m 1024 -usbdevice tablet -name 'Windows W' -soundhw es1370 -hda /home/tbl/VirtualMachines/Win7.img
component: qemu
executable: /usr/bin/qemu-kvm
kernel: 2.6.32.2-15.fc13.x86_64
package: qemu-system-x86-2:0.12.1.2-2.fc13
rating: 4
reason: Process was terminated by signal 6 (Aborted)
Comment 1 Tom London 2010-01-06 09:38:43 EST
Created attachment 382004 [details]
File: backtrace
Comment 2 Tom London 2010-01-06 09:43:42 EST
Here is console output.  

BTW, the core dump is over 1GB, so I did not attach.

Downgrading to 
  qemu-common.x86_64 2:0.11.0-12.fc13  qemu-img.x86_64 2:0.11.0-12.fc13        
  qemu-kvm.x86_64 2:0.11.0-12.fc13     qemu-system-x86.x86_64 2:0.11.0-12.fc13 

makes it "work again".

[tbl@tlondon ~]$ win7
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
qemu: hardware error: register_ioport_write: invalid opaque
CPU #0:
EAX=00000405 EBX=00000004 ECX=00000004 EDX=00000cfc
ESI=00000cfc EDI=00000002 EBP=86e03a44 ESP=86e03a34
EIP=81619062 EFL=00200206 [-----P-] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0023 00000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
CS =0008 00000000 ffffffff 00c09b00 DPL=0 CS32 [-RA]
SS =0010 00000000 ffffffff 00c09300 DPL=0 DS   [-WA]
DS =0023 00000000 ffffffff 00c0f300 DPL=3 DS   [-WA]
FS =0030 81760c00 00003748 00409300 DPL=0 DS   [-WA]
GS =0000 00000000 ffffffff 00000000
LDT=0000 00000000 ffffffff 00000000
TR =0028 801a6000 000020ab 00008b00 DPL=0 TSS32-busy
GDT=     81473000 000003ff
IDT=     81473400 000007ff
CR0=8001003b CR2=8989a000 CR3=00185000 CR4=000006f8
DR0=00000000 DR1=00000000 DR2=00000000 DR3=00000000 
DR6=ffff0ff0 DR7=00000400
FCW=027f FSW=0000 [ST=0] FTW=00 MXCSR=00000000
FPR0=0000000000000000 0000 FPR1=0000000000000000 0000
FPR2=0000000000000000 0000 FPR3=0000000000000000 0000
FPR4=0000000000000000 0000 FPR5=0000000000000000 0000
FPR6=0000000000000000 0000 FPR7=0000000000000000 0000
XMM00=00000000000000000000000000000000 XMM01=00000000000000000000000000000000
XMM02=00000000000000000000000000000000 XMM03=00000000000000000000000000000000
XMM04=00000000000000000000000000000000 XMM05=00000000000000000000000000000000
XMM06=00000000000000000000000000000000 XMM07=00000000000000000000000000000000
Aborted (core dumped)
[tbl@tlondon ~]$
Comment 3 Tom London 2010-02-10 09:58:12 EST
This has been working for several qemu updates, in particular with

qemu-system-x86-0.12.2-6.fc13.x86_64
qemu-img-0.12.2-6.fc13.x86_64
qemu-common-0.12.2-6.fc13.x86_64
qemu-debuginfo-0.12.2-5.fc13.x86_64
qemu-kvm-0.12.2-6.fc13.x86_64


I still get the "BUG: kvm_dirty_pages_log*: invalid parameters" messages, but the VM runs just fine.

I'll close this and file the "BUG:*" issue elsewhere.

Note You need to log in before you can comment on or make changes to this bug.