Bug 55307 - /sbin/iscsid linked against /usr library
/sbin/iscsid linked against /usr library
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iscsi (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 58241 61529 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 10:44 EST by Kambiz Aghaiepour
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-02 15:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kambiz Aghaiepour 2001-10-29 10:44:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-6 i686)

Description of problem:
/sbin binaries should not rely on /usr. This breaks when /usr is on a
separate partition.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
up2date system

Additional info:
Comment 1 Michael K. Johnson 2002-05-02 15:32:17 EDT
*** Bug 61529 has been marked as a duplicate of this bug. ***
Comment 2 Michael K. Johnson 2002-05-02 15:32:40 EDT
*** Bug 58241 has been marked as a duplicate of this bug. ***
Comment 3 Michael K. Johnson 2002-05-02 15:35:11 EDT
iscsi-2.1.0.20-5 fixes this by linking staticly against libstdc++, but
dynamically against libc and libm.

Note You need to log in before you can comment on or make changes to this bug.