Bug 55324 - "loop.o: unresolved symbol" w/ 2.4.9-7.5
"loop.o: unresolved symbol" w/ 2.4.9-7.5
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Sainty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 13:43 EST by David Sainty
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 06:35:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Sainty 2001-10-29 13:43:10 EST
Description of Problem:
w/ 2.4.9-7.5 kernel loaded w/ install image (RDR), I mount /dev/dasda1 (/)
and chroot - to install a new kernel.

rpm -ivh <new kernel rpm> works;  mkinitrd fails since loop.o is required.
loop.o cannot be insmod'ed because:

bash-2.05# /sbin/insmod /lib/modules/2.4.9-7.5/kernel/drivers/block/loop.o
/lib/modules/2.4.9-7.5/kernel/drivers/block/loop.o: unresolved symbol
generic_make_request_Rsmp_31f0df97
/lib/modules/2.4.9-7.5/kernel/drivers/block/loop.o: unresolved symbol
blk_queue_make_request_Rsmp_9e6e41d1

arjan's comments:

<arjan> saint: oh that's a s390 specific bug
<arjan> it needs a define in a header
...
<saint> arjan: is it already fixed?
<arjan> not 100% sure

Version-Release number of selected component (if applicable):
Installer env. from 7.2 RC2
kernel-2.4.9-7.5

How Reproducible:
Always

Steps to Reproduce:
1. see above.
Comment 1 Harald Hoyer 2001-11-05 06:34:40 EST
retry with 2.9.7-9.1 or 2.9.7-13
Comment 2 Harald Hoyer 2001-11-05 06:35:14 EST
oops, meant 2.4.9, of course :)
Comment 3 Karsten Hopp 2001-11-13 07:30:49 EST
You need to do the insmod before you chroot ! The modules of the -BOOT kernel
are not copied into the chroot directories.
insmod loop.o works for me.
Comment 4 Harald Hoyer 2001-11-13 08:08:34 EST
good point, karsten

Note You need to log in before you can comment on or make changes to this bug.