Bug 55333 - System hangs during boot if more than 99 SCSI LUNs exist.
System hangs during boot if more than 99 SCSI LUNs exist.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 15:45 EST by Wayne Berthiaume
Modified: 2014-03-16 22:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 11:45:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
results of: strace() -o fstrace /usr/sbin/updfstab (deleted)
2001-10-29 15:49 EST, Wayne Berthiaume
no flags Details
results of: strace -o fstrace /usr/sbin/updfstab (deleted)
2001-10-29 15:54 EST, Wayne Berthiaume
no flags Details
results of: strace -o fstrace /etc/updfstab (5.01 KB, text/plain)
2001-10-31 11:25 EST, Wayne Berthiaume
no flags Details
Results of: cat /proc/partitions (6.95 KB, text/plain)
2001-10-31 11:34 EST, Wayne Berthiaume
no flags Details
Results of: cat /proc/scsi/scsi (20.41 KB, text/plain)
2001-10-31 11:35 EST, Wayne Berthiaume
no flags Details

  None (edit)
Description Wayne Berthiaume 2001-10-29 15:45:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2smp i686)

Description of problem:
The system hangs during boot if more than 99 LUNs exist. If I disconnect
the HBA from the storage that contains 100 LUNs I'm able to bring the
system up. Then I can reconnect the HBA to the storage device, restart the
HBA driver module, and the system will run fine until the next reboot. I've
isolated it to a binary called by kudzu, /usr/sbin/updfstab. I ran strace()
against it and will submit it as an attachment.

Version-Release number of selected component (if applicable):
kudzu-0.98.10-1

How reproducible:
Always

Steps to Reproduce:
1.Create more than 99 SCSI LUNs
2.Create an initial RAM disk with the storgae devices driver module in it.
3.Reboot the system so the HBA is up before kudzu is called.
	

Actual Results:  System reports "Updating /etc/fstab:" and hangs.

Expected Results:  System should report "Updtaing /etc/fstab:       {OK}"
and continue the reboot.

Additional info:

This is occurring with both the 2.4.2 and 2.4.3 kernels I have tried. I'm
unable to find any source files for updfstab so I'm unable to try and
determine the root cause of the failure. Testing done on RH 7.0 and 6.2 do
not have this problem.
Comment 1 Wayne Berthiaume 2001-10-29 16:22:52 EST
Get an error while trying to add the attachment. Can send the file as an email
attachment.
Comment 2 Bill Nottingham 2001-10-29 16:46:41 EST
What is the error?
Comment 3 Wayne Berthiaume 2001-10-29 16:59:17 EST
DBD::Oracle::st execute failed: ORA-01691: unable to extend lob segment 
BUGZILLA.SYS_LOB0000003839C00008$$ by 972 in tablespace ENG_DATA02 (DBD ERROR: 
OCILobTrim/OCILobWrite/LOB refetch) 
at /var/www/bugzilla/bugzilla/createattachment.cgi line 124.

I've forwarded it to webmaster@redhat.com.
Comment 4 Bill Nottingham 2001-10-29 20:57:47 EST
Temporary DB error - please retry. It will be faster than sending it to
webmaster. :)
Comment 5 Bill Nottingham 2001-10-29 23:23:46 EST
Alternatively, post the /proc/scsi/scsi file.
Comment 6 Wayne Berthiaume 2001-10-31 11:25:41 EST
Created attachment 35842 [details]
results of: strace -o fstrace /etc/updfstab
Comment 7 Wayne Berthiaume 2001-10-31 11:31:48 EST
The attachment is now there. The comments are incorrect; however.... =%^)

The strace() was performed on /usr/sbin/updfstab. The only work-around I have at
the moment is to comment updfstab() out of the kudzu init script.
Comment 8 Wayne Berthiaume 2001-10-31 11:34:57 EST
Created attachment 35843 [details]
Results of: cat /proc/partitions
Comment 9 Wayne Berthiaume 2001-10-31 11:35:59 EST
Created attachment 35844 [details]
Results of: cat /proc/scsi/scsi
Comment 10 Bill Nottingham 2001-10-31 11:43:54 EST
This was fixed in kudzu-0.99.1. It should work fine in 7.2.

Note You need to log in before you can comment on or make changes to this bug.