Bug 55336 - installer crashes quickly
installer crashes quickly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 16:41 EST by John J. O'Rourke
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 01:38:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John J. O'Rourke 2001-10-29 16:41:39 EST
Description of Problem:


Version-Release number of selected component (if applicable):


How Reproducible:


Steps to Reproduce:
1. Boot Dell Inspiron 8100 laptop with 7.1 cd
choose all the settings 
2. Choose any packages (custom, laptop or etc)
3. choose network settings 
4. start install

after gui says its formating disks it crashes

Actual Results:
shutting down
install exited abnormally 




Expected Results:


Additional Information:
Comment 1 Need Real Name 2001-10-30 00:03:37 EST
I added an attachment as I'm having the same problem.  Doesn't matter what file 
system I try to use in building the system, I get errors, it crashes install, 
and allows me to create the dump save.

Also happens if I attempt to upgrade.  I was able to install RedHat Linux 5.2 
(very old copy I had) and then tried to update with the same results.
Comment 2 Need Real Name 2001-10-30 00:08:14 EST
I forgot to mention this:
Installing purchased RedHat Linux 7.2 Standard from CDROM.
Comment 3 Brent Fox 2001-10-30 15:30:25 EST
Do either of you have a debug error message that you can attach?  I don't have
anything to go on otherwise.
Comment 4 Need Real Name 2001-10-30 17:15:43 EST
I sent a copy of anacdump.txt directly to bfox@redhat.com.  I tried to post a 
copy here last night but might have not done it correct.
Comment 5 John J. O'Rourke 2001-10-30 17:40:40 EST
I have not been able to get 7.1 to work at all. One of my problems is that this 

is the fifth Dell 8100 laptop. I installed 7.1 on the first four laptops with out 

a problem. All laptops are the same.

I have downloaded the new RH 7.2 iso images and that has seemed to work. It 

installed fine and even noticed the right video card. I still had to play with 

the X86Config file, load 7.1 NVIDIA_GLX video driver and a NVIDIA_kernel, but I 

have the laptop running and all seems to be well.



I'm still very interested in what happened



<John>

Comment 6 Brent Fox 2001-10-30 19:21:15 EST
Bugzilla seems to have had some problems accepting attachments lately.  I don't
know what the problem with Bugzilla is.
Comment 7 Brent Fox 2001-10-30 19:22:28 EST
Here's the debug error message that fryshome sent to me:


Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line 408, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 143, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line 434, in doPreInstall
    method.mergeFullHeaders(id.hdList)
  File "/usr/lib/anaconda/image.py", line 26, in mergeFullHeaders
    hdlist.mergeFullHeaders(self.tree + "/RedHat/base/hdlist2")
  File "/usr/lib/anaconda/comps.py", line 161, in mergeFullHeaders
    rpm.mergeHeaderListFromFD(self.hdlist, fd, 1000004)
rpm.error: match tag mismatch

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 8342020>
file: /mnt/source/RedHat/base/hdlist2
fd: 24


Package Group selection status:
Base: 1
Printing Support: 1
Classic X Window System: 1
X Window System: 1
Laptop Support: 0
Spelling: 0
GNOME: 1
KDE: 0
Sound and Multimedia Support: 1
Network Support: 1
Dialup Support: 1
Messaging and Web Tools: 1
Graphics and Image Manipulation: 0
Network Server: 0
News Server: 0
NFS File Server: 0
Windows File Server: 0
Anonymous FTP Server: 0
SQL Database Server: 0
Web Server: 0
Router / Firewall: 0
DNS Name Server: 0
Network Managed Workstation: 0
Authoring and Publishing: 0
Emacs: 0
Utilities: 0
Legacy Application Support: 0
Software Development: 1
Kernel Development: 0
Windows Compatibil
Comment 8 Brent Fox 2001-10-31 00:39:57 EST
fryshome, the traceback you are seeing looks like a cdrom problem to me.  The
install is looking for the hdlist2 file on the cd, and it's not able to find it.
 Can you try the install on another machine and see if it's related to the cdrom
drive of the laptop in any way?
Comment 9 Need Real Name 2001-10-31 01:38:51 EST
I found the problem.  I removed the existing memory and replaced it (+ added a 
bunch to be sure).  The software installed and I'm just playing with 
configuration stuff for my display now.  So, memory was the issue.
Comment 10 Brent Fox 2001-10-31 08:26:27 EST
Ok.  I'm glad the problem has disappeared.  Closing now as CurrentRelease, since
7.2 seems to fix the original poster's problem with 7.1

Note You need to log in before you can comment on or make changes to this bug.