Bug 55352 - System completely freezes on fast mouse movement
System completely freezes on fast mouse movement
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 00:54 EST by Calvin Webster
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 22:22:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Running processes in typical session. (4.46 KB, text/plain)
2001-11-09 22:20 EST, Calvin Webster
no flags Details
Kernel modules loaded during typical session. (762 bytes, text/plain)
2001-11-09 22:22 EST, Calvin Webster
no flags Details

  None (edit)
Description Calvin Webster 2001-10-30 00:54:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-7 i686)

Description of problem:
When moving mouse cursor rapidly all system functions cease - Keyboard,
display, and mouse all stop working. Cannot even ping or telnet to machine
from LAN.

Two days since upgrade from RHL 7.1 to 7.2 - both days experienced lock-up.
Yesterday during srolling of image in "GQview" when rapidly shifing pointer
position to file selection frame. Today after selecting a block of text in
"gedit" then rapidly right-clicking for the pop-up edit menu.

Notes: (1) First failure occurred prior to kernel upgrade (to 2.4.9-7).
Second failure occurred several hours after upgrade.
(2) 7.1 would occasionally lock-up the display during same actions, but
<Ctrl><Alt><Backspace> would reset "gdm". Also, I could still ping and
telnet to the machine.

Version-Release number of selected component (if applicable):
Kernel ver. 2.4.9-7 (and 2.4.7-10)

How reproducible:
Sometimes

Steps to Reproduce:
1. Login to Gnome Desktop.
2. Start an ftp or usenet download
3. Open GQview and click down through some large images, moving the
larger-than-frame images around with the mouse to view hiddent extents.
4. After viewing several large images, rapidly move the pointer to the file
selection frame and select several images, then delete them and rapidly go
back to scrolling through images.
[OR]
1. Establish a dialup connection in the Windows NT guest OS of VMware.
2. begin downloading several large files over the dial-up connection.
3. Minimize VMware window and begin editing a large document in "gedit",
cutting and pasting the contents in different places using the right-click
pop-up edit menu.
	

Actual Results:  The system locks up completely. I've only been able to
duplicate this failure during intermittent episodes of editing text or
viewing graphics images.

Expected Results:  Expect that I should be able to use the full resources
of this computer without it freezing up.

Additional info:

CPU, Memory, Disk and Network loads were light (gkrellm).
Each episode occurred while background transfers were in progress and some
graphics application was running (GQview/VMware).

Hardware Profile:
Dell Dimension XPS B733 (PIII 733)
Ultra ATA Seagate 80GB
EIDE Western Digital 10GB
384 MB RAM
=========== /etc/sysconfig/hwconf ===========
desc: "Intel Corporation|82820 820 (Camino) Chipset Host Bridge (MCH)"
desc: "Intel Corporation|82820 820 (Camino) Chipset PCI to AGP Bridge"
desc: "Intel Corporation|82801AA PCI Bridge"
desc: "Intel Corporation|82801AA ISA Bridge (LPC)"
desc: "Intel Corporation|82801AA IDE"
desc: "Intel Corporation|82801AA SMBus"
desc: "Creative Labs|SB Live!"
desc: "USB UHCI Root Hub"
desc: "ViewQuest Technologies, Inc. Intel Pro Share WebCam"
desc: "3Com Corporation|3c905C-TX [Fast Etherlink]"
desc: "Generic 3 Button Mouse (PS/2)"
desc: "Creative Labs|SB Live! EMU10000"
desc: "Lg CD-RW CED-8080B"
desc: "US Robotics/3Com|56K FaxModem Model 5610"
desc: "nVidia Corporation|Vanta [NV6]"
desc: "LS-120 VER5 00 UHD Floppy"
desc: "ST380021A"
desc: "WDC WD102AA"
desc: "Brooktree Corporation|Bt848 TV with DMA push"
desc: "Intel Corporation|82801AA USB"
=============================================

Active Software Profile:

RedHat Linux 7.1
    ->Samba
    ->sshd
    ->xinetd
    ->lpd
    ->Sendmail
    ->vmnet (VMware)
    ->rhnsd
    ->Gnome->Sawfish

VMware (WinNT WS4, 128MB, 2GB)->Dial-Up Networking->SMB File Transfer
GKrellm
gedit
Netscape->Navigator & Messenger

Substitute "GQview" and "Pan" for "gedit" and "VMware" during first
episode.
Comment 1 Mike A. Harris 2001-10-30 05:37:53 EST
VMware installs its own kernel modules into the running kernel.
Red Hat does not support the usage of kernel modules supplied
from external sources.  Please let the VMware people know about
this problem, so they can look into it, and hopefully fix it.

I note that you're also using an Nvidia video card.  If you are
using Nvidia's closed source proprietary binary only video driver,
Red Hat also does not support that, for the same reasons.  If so,
be sure to also inform Nvidia of the problem, in case it is
related to their driver, so they can fix any problems their
driver may be causing also.
Comment 2 Calvin Webster 2001-11-09 22:17:10 EST
After living with this problem for some time now, it does not appear to be
related to any specific application program. The last two times the system froze
I was running only "gedit", krellm, and a terminal window. Just now, when
attempting to write this update it froze again, without any apparent
provocation.

I have attached two files, one containing a list of running processes and the
other, a list of loaded modules.

It does appear that the NVida video driver is installed. These files are located
in /usr/src/linux-2.4.9-13/drivers/video/riva:

==> accel.c <== Copyright 2000 Jindrich Makovicka, Ani Joshi
==> fbdev.c <== Copyright 1999-2000 Jeff Garzik
==> nv4ref.h <== Copyright 1993-1998 NVIDIA, Corporation.
==> nvreg.h <== Copyright 1996-1997  David J. McKay
==> riva_hw.c <== Copyright 1993-1999 NVIDIA, Corporation.
==> riva_hw.h <== Copyright 1993-1999 NVIDIA, Corporation.
==> riva_tbl.h <== Copyright 1993-1999 NVIDIA, Corporation.

This is the default driver from the RedHat installation. If you think this could
be the source of this lock up, please point me to where I can find a less
troublesome driver.

I don't think it's likely VMware is causing this. I've installed the newest 3.0
software and built drivers on this machine during the setup. Besides, I haven't
heard of anyone else complaining of system freeze from VMware.

Is it possible that my compiler is the problem? I'm using the compiler installed
by default during the system installation with whatever updates have been
available. 

While building the VMware modules, I got this warning:

As of October 2001, Gcc 2.96 is not yet a supported compiler by the Linux
kerneldevelopment team. Have a look at /usr/src/linux/Documentation/Changes to
get thecorrect compiler installed. This script will take into consideration the
CC environment variable. Do you want to go with gcc version 2.96 compiler ? 

If the problem is the compiler, why do we have a problematic compiler packaged
with the 7.2 distribution?

If the problem is the video driver, why do we have a problematic compiler
installed by default?

I would appreciate any information or recommendations you might offer. Thank you
for your help!

--Cal Webster
Comment 3 Calvin Webster 2001-11-09 22:20:18 EST
Created attachment 37141 [details]
Running processes in typical session.
Comment 4 Calvin Webster 2001-11-09 22:22:25 EST
Created attachment 37142 [details]
Kernel modules loaded during typical session.
Comment 5 Mike A. Harris 2001-11-10 12:15:16 EST
As I mentioned earlier, VMware is not supported by Red Hat Linux.

What this means in a larger sense, is that, if one encounters a
bug, system lockup, or similar, either while using VMware, after
using VMware, or after any of the VMware kernel modules have even
been loaded once, any problems encountered at all from that point
on, are not supported by Red Hat.  We also do not officially
support installing Red Hat Linux into a VMware virtual machine.

We encourage users experiencing bugs with external kernel modules
having been used, to reconfigure their system to disable all
external modules, reboot, and run their system in the default
supplied configuration to reproduce the problem.  This holds
true for any external software providing its own kernel modules,
or directly accessing hardware.

>As of October 2001, Gcc 2.96 is not yet a supported compiler by
>the Linux kernel development team. Have a look at
>/usr/src/linux/Documentation/Changes to get the correct compiler
>installed. This script will take into consideration the
>CC environment variable. Do you want to go with gcc version 2.96
>compiler ?

The compiler supported and used officially by Red Hat Linux for
all 7.x releases, is gcc 2.96, which has been used to compile
_all_ of the Red Hat 2.4.x kernels, which subsequently pass
intense cerberus testing, as well as other Quality Assurance
testing before our kernels are released officially.  The 2.2
series kernels in 7.0 were build with the older egcs due to
kernel bugs (not compiler bugs).

ftp.kernel.org shows the datestamp for the 2.4.10 kernel as:
-rw-r--r--   1 korg     korg     22911818   Sep 23 18:30   linux-2.4.10.tar.bz2

Here is an excerpt from the linux/Documentation/Changes:

 The Red Hat gcc 2.96 compiler subtree can also be used to build this tree.
 You should ensure you use gcc-2.96-74 or later. gcc-2.96-54 will not build
 the kernel correctly.
So, clearly the VMware statement is not accurate.  Either way
however, whatever compiler you use, or VMware recommends to use,
is what you need to use to get support from VMware, using their
technical support channels.  Red Hat does not support VMware.

The following document may also be of use for general gcc 2.96
information:    http://www.bero.org/gcc296.html
We absolutely are interested in knowing about bugs encountered
in valid supported software configurations that do not include
unsupported add on kernel modules.  If you can reproduce this
bug, as described above, without having loaded or used VMware
from a fresh reboot, then we can look into this further, and
encourage you to reopen the report, with any new updated info.
Also, since VMware is involved, it would be a good idea to
contact their technical support and/or bug tracker, to inform
them of the problem as well and ensure that they can track
any software bugs that may possibly be found in their product.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.