Bug 55366 - SAMBA + Windoze XP WORKGROUP networking issue
SAMBA + Windoze XP WORKGROUP networking issue
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
http://helpme.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 07:25 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-06 00:23:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-10-30 07:25:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.12-0.1smp i686)

Description of problem:
I'm running RHLinux 7.1 (Seawolf) with k2.4.12-0.1SMP  and many errata
updates including glibc(which like k2.4.9 is also 
running super - no lockups or crashes yet).   I installed VMWare's  
VMwareWorkstation-3.0.0-1447  near-release product and installed 
WindrugsX-tra P-roblems in a virtual disk - and very surprisingly all is
working very well and highly stable thus far (speaking mainly from a Linux 
+ VMware  aspect).  However I am wondering about a particular neworking
piece of it related to SAMBA+Linux and Windose XP 
WORKGROUP networking. (VMware has not gotten back to me on it, and I doubt
MS will want anything to do with it.)   If you can't help, please 
advise if you can forward this to the right guys, etc. ?

I currently run a ethernet network with RHLinux 7.1, Windoze Me, Windoze 95
and with a specific registry fix given to me from a redhat.de technician 
applied to Me to enable plain text passwords, this is all working quite
well as a workgroup network.   My Linux's Samba is version samba-2.0.10-2  
which was also part of the fix to make it work (ie. latest).

But since bringing up XP living up to its name here-to-for explicated, and
setting up WORKGROUP networking and file sharing, when I click on "My 
Network Places / View Workgroup Computers"  I get an error message
"Workgroup not accessible. You might not have permission to use this
network 
resourse. Conact Administrator.... The account is not authorized to login
from this station."      I AM WONDERING if there is yet more MS-style BS 
built into XP's WORKGROUP computing/security which is disallowing
SAMBA/Linux from networking with it until we apply some kind of registry
fix 
or patch to XP to unbreak it.   (Sort of like I had to do with Me.)  
Further, Linux smbclient -L XPbox can see XP box, but not access it's file
systems, 
and same for 95 and patched Me.   TCPIP is all working find - ever box can
ping all the others, and yes I have the correct MS stacks and services 
loaded on XP for workgrouping.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Redhat Linux 7.1 + kernel 2.4.9 or 2.4.12 
2. Install WIndoze XP on the same network or under VMware 3.0.0
3. Setup SAMBA and Workgroup networking on XP + View Workgroup Computers
	

Actual Results:  Click "My Network Places / View Workgroup Computers"  I
get an error message "Workgroup not accessible. You might not have
permission to use this network 
resourse. Conact Administrator.... The account is not authorized to login
from this station."      I AM WONDERING if there is yet more MS-style BS 
built into XP's WORKGROUP computing/security which is disallowing
SAMBA/Linux from networking with it until we apply some kind of registry
fix.  THE ID I AM LOGGING IN AS IS A ADMINISTRATOR EQUIVALENT on XP. 

Expected Results:  Should show all the workgroup resources, much like 
smbclient -L XPboxName or LinuxboxName.

Additional info:

I previously had to add a registry fix (given to me from REDHAT.DE
technician up here in a previous Samba bugzilla entry) to open up plain
text passwords, so does XP need something to make workgrouping work with
Samba and older Windoze OS's ???
Comment 1 Trond Eivind Glomsrxd 2001-11-05 11:56:20 EST
Try the samba packages included in RHL 7.2 (2.2.1a), if that doesn't succeed,
try asking on one of samba lists you can find listed at http://www.samba.org or
one of the Red Hat mailing lists (http://www.redhat.com/mailing-lists/)
Comment 2 Andrew Bartlett 2001-11-06 00:23:28 EST
I would suggest running with encrypted passwords, thats what that messege
usually indicates.  MS just does not test plaintext passwords, and there are a
*lot* of bugs if you use them.
Comment 3 Trond Eivind Glomsrxd 2002-07-25 19:27:42 EDT
Closing as a "use encrypted password, local configuration" issue.

Note You need to log in before you can comment on or make changes to this bug.