Bug 55367 - IPCP timeout with MS clients (No network protocols running)
IPCP timeout with MS clients (No network protocols running)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: ppp (Show other bugs)
7.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
: 55776 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 07:57 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-27 12:46:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file to disable CBCP, this solves the problem (5.83 KB, text/plain)
2001-10-30 07:59 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-30 07:57:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
pppd acting as dial-in server.  When Microsoft client dials in
pppd tries to send IPCP ConfReq-s with protocol parameters but
the client does not respond, so a pppd terminates after
"IPCP: timeout sending Config-Requests" with LCP TermReq
"No network protocols running"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. configure pppd as dialin server
2. dialin with Microsoft Windows (any) client


Additional info:
Comment 1 Need Real Name 2001-10-30 07:59:26 EST
Created attachment 35681 [details]
spec file to disable CBCP, this solves the problem
Comment 2 Need Real Name 2001-11-07 07:42:55 EST
I had exactly the same problem. It seemed to be problem with ppp-2.4.1. 

Downgrading to ppp-2.4.0 allowed the windows ppp client to login and 

connect sucessfully.
Comment 3 Frank Ch. Eigler 2001-11-27 15:39:53 EST
See also bug 15738.
Comment 4 Frank Ch. Eigler 2001-11-28 11:36:34 EST
Given that this is a serious regression from RHL 7.1, it may
be appropriate to increase the priority of this bug.
Comment 5 Frank Ch. Eigler 2001-12-06 13:44:27 EST
*** Bug 55776 has been marked as a duplicate of this bug. ***
Comment 6 Iarno Pagliani 2001-12-22 12:49:50 EST
I had exactly the same problem with pptp-1.0.1 and ppp-2.4.1
I had downgrading to ppp-2.4.0 and all it's ok.
Comment 7 Need Real Name 2001-12-24 04:19:36 EST
I ran into the same problem after upgrading my ppp server to redhat 7.2.
I also tracked it down to the CBCP patch and edited the specfile to exclude it
and problem solved.

Please fix this as it will be a huge problem for ISPs out there, I have src.rpm
and binary rpm available should anyone need them email me.
Comment 8 Aleksey Nogin 2001-12-24 15:41:13 EST
I agree that this is a pretty serious problem.
Comment 9 Geoffrey D. Bennett 2001-12-28 08:32:39 EST
For those who want a prebuilt RPM that fixes the problem, see
http://www.netcraft.com.au/rpms/
Comment 10 Yoda 2001-12-28 22:41:41 EST
RH needs to publish an update for this soon.  If this was on the update site it
would have been fixed immediately.

Maybe a command line option for this would be appropriate.

Thanks
Comment 11 Need Real Name 2002-01-01 01:19:09 EST
As I stated to the 15738 bug, the patch from michael brown @ dell is a bad
patch. It
breaks ppp when
 Linux acts as the dialin server for a Windows client. This patch accepts the
CBCP request from 
the windows client, while it has neither the intention nor the ability to act as
a CBCP server. 
The problem is entirely a problem with this patch.

Please issue a revised pppd which removes this patch. It is inappropriate and
breaks ppp.

In the meantime, for all users who read this, either get the ppp 2.4.1 source
tar from 
ftp.samba.org/pub/ppp or get the Mandrake rpm from Mandrake 8.1 which does not 
include this patch.



Comment 12 Need Real Name 2002-02-06 17:44:35 EST
W2000 is actually able to connect to ppp that comes with rh7.2, while W98 is 
not.
Comment 13 Need Real Name 2002-02-06 20:27:15 EST
The rpm packages at http://www.netcraft.com.au/rpms/
have tested OK for the described bug.

I have also applied a patch (static_ip) which never made it into the
+ppp-sources,
that makes it very easy to assign static IP-addresses by listing
them in file /etc/ppp/statics - The original patch for ppp-2.2.0f
by ben@sesnet.com (unknown e-mail now) is still around at sunsite, see
ftp://sunsite.unc.edu/pub/Linux/system/network/serial/ppp/ppp-static-patch-1.1
+.lsm
but has not been maintained since 1998 (ver 1.1)

A previous patch (wtmp) broke the ability for the 'w'
command to display a logged-on user when acting as a
dial-in server. I have applied a patch (fix_w) for this as well.

Tested with
- Windows 2000 client
- Windows 98 client

Updated spec file, patches and RPM-packages
are at: ftp://ftp.snerpa.is/pub/linux/ppp/

Feel free to critic, copy, publish, use et. cetera.
Comment 14 Nalin Dahyabhai 2002-02-27 17:20:25 EST
Reverting.  An errata is pending.  I need to take a closer look at the wtmp
issue, but at first glance it appears to be more of a permissions problem than
an actual bug (glibc provides a logwtmp() function, which is always preferable
to a locally-defined one).
Comment 15 Nalin Dahyabhai 2002-02-27 17:31:19 EST
Fixed for Raw Hide (will show up in the next refresh), will resolve this as
ERRATA when it's pushed out.
Comment 16 Matthew Galgoci 2002-03-28 12:48:48 EST
I rebuild the ppp in current rawhide (may not be out yet) and tested it. It does 
indeed seem to fix the problem.
Comment 17 Need Real Name 2002-04-01 14:20:52 EST
Please, please put out an errata for 7.2 on this bug. It continues to waste
hours or your user's time, and peple like me have to tell them where to find the
fix burried in rawhide.
Comment 18 Oliver Schulze L. 2002-04-05 09:44:05 EST
I tested this file:
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/ppp-2.4.1-3.i386.rpm
and is working.
I thing there should be an errata, because RH7.2 really needs a dial-up server.
Comment 19 Need Real Name 2002-04-27 12:46:20 EDT
Over a day wasted sorting this. Please publish an errata for those poor saps 
like me out there  :(
Comment 20 Nalin Dahyabhai 2002-05-01 08:47:26 EDT
Pushing as RHBA-2002:037.

Note You need to log in before you can comment on or make changes to this bug.