Bug 55394 - interface aliases don't work
interface aliases don't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 14:35 EST by Jürgen Botz
Modified: 2008-05-01 11:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-20 04:42:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this is a patch which fixes it... or at least it works fine for me. (1.43 KB, patch)
2001-11-04 17:53 EST, Dan Moore
no flags Details | Diff
this patch should be applied after dcm.NCProfileList.patch1. patch1 just fixed the UI, this one actually fixes the code that writes the files (1.76 KB, patch)
2001-11-05 10:40 EST, Dan Moore
no flags Details | Diff

  None (edit)
Description Jürgen Botz 2001-10-30 14:35:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
interface device aliases can't be configured.  it lets you define one, but
if you try to save it complains that interface eth0 already exists and
refuseses to define it.  I've tried all combinations of clicking the alias
support checkbox on both the real and alias device and just the alias
device (it's unclear which it wants, that should be clarified in the
interface) but nothing works.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.define a device nick:eth0real, hw ethernet
2.define another device, nick eth0alias, hw ethernet, click alias support,
set number 1
3.try to apply
	

Actual Results:  Error dialog sez:
"Device eth0alias uses the same Hardware Device "eth0" like eth0real!
Please select another Hardware Device or activate only one of them."

Expected Results:  Create new interface config eth0:1

Additional info:

In the error, what does"activate only one" mean?  Not choosing "activate at
start" on either or both doesn't help.  I don't see any other applicable
sense of word "activate".
Comment 1 Dan Moore 2001-11-04 17:53:37 EST
Created attachment 36401 [details]
this is a patch which fixes it... or at least it works fine for me.
Comment 2 Dan Moore 2001-11-05 10:40:17 EST
Created attachment 36461 [details]
this patch should be applied after dcm.NCProfileList.patch1.  patch1 just fixed the UI, this one actually fixes the code that writes the files
Comment 3 Dan Moore 2001-11-05 11:32:33 EST
i just found out about the CVS repository.

looks like all but one thing in my patches have already been addressed:

*** NCProfileList.py	Thu Oct 25 09:27:05 2001
--- NCProfileList.py.FIXED	Mon Nov  5 11:38:55 2001
***************
*** 212,218 ****
          filelist = os.listdir(SYSCONFPROFILEDIR+'/default')
          for file in filelist:
              try:
!                 os.unlink(OLDSYSCONFDEVICEDIR+'/default/'+file)
              except:
                  pass
  
--- 212,218 ----
          filelist = os.listdir(SYSCONFPROFILEDIR+'/default')
          for file in filelist:
              try:
!                 os.unlink(SYSCONFPROFILEDIR+'/default/'+file)
              except:
                  pass
Comment 4 Harald Hoyer 2001-11-20 04:42:29 EST
thx man! stay tuned! 
;o)
Comment 5 Jay Turner 2002-08-14 14:48:27 EDT
redhat-config-network-1.1.15-1 now automatically creates ethernet alias and they
work post configuration.

Note You need to log in before you can comment on or make changes to this bug.