This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 55395 - GRUB Splash Image Corrupt
GRUB Splash Image Corrupt
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: grub (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 51876 71605 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 14:41 EST by John Verel
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-18 13:31:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Verel 2001-10-30 14:41:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win95; U)

Description of problem:
7.2 Installed on Toshiba Tecra 530 Laptop, grub splash image appears 
corrupt, unreadible.  Same result if image is unzipped.  Workaround:  
comment out splash screen in grub.conf.  Result occurred in 3 of 3 
installations.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install/upgrade 7.2
2.Boot
3.See corrupt screen
	

Actual Results:  Screen was mostly unreadible.  Part of RedHat Logo 
legible.

Expected Results:  Normal splash image.

Additional info:
Comment 1 Jeremy Katz 2001-10-31 17:30:50 EST
Can you verify that the image does load properly if you look at it with say the
gimp?

Also, since this is a laptop LCD, is there a way to switch between stretched to
fill display when in a lower res or just using part of the screen?  If so, does
switching between these make any difference?
Comment 2 John Verel 2001-11-01 11:57:00 EST
I confirm that the image, unzipped, loads correctly with the gimp.

The BIOS for this machine has the option of using "stretch".  Changing to the 
stretch setting has no effect on this problem.  I tried it with both the zipped 
as well as an unzipped version of the image, both living in /boot/grub.

There are no other resolution settings availible in the BIOS.  The BIOS is the 
most recently available from Toshiba.  The default color setting, which cannot 
be changed, is 16 million colors.

The top half of the image is completely garbled, including the Shadow Man 
image.  The bottom half is readible, in particular the words Red Hat.
Comment 3 sdh4 2001-11-11 18:01:40 EST
Same problem on Toshiba 220CDS. The splash screen itself is fine. It's the text
on top of the splash screen that is entirely corrupted. (Wrong char-set or font?)
Likewise, disabling the splash image solves the problem.
Comment 4 Mace Moneta 2001-11-18 12:05:04 EST
Same problem on Toshiba Tecra 730CDT.
Comment 5 Need Real Name 2002-01-06 08:34:03 EST
Same on a Toshiba 440CDT.  The image is fine.  The text which is written on top of it is garbled
Comment 6 Jeremy Katz 2002-03-08 16:11:40 EST
*** Bug 51876 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2002-08-18 13:31:48 EDT
*** Bug 71605 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2002-10-31 18:17:40 EST
This is a BIOS bug in that it doesn't properly support the standard vga16 video mode

Note You need to log in before you can comment on or make changes to this bug.