Bug 554022 - UMS:RV620 Resume from suspend fails
UMS:RV620 Resume from suspend fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Jérôme Glisse
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-09 20:49 EST by António Lima
Modified: 2010-12-03 19:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 19:38:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.conf (1019 bytes, text/plain)
2010-01-09 20:49 EST, António Lima
no flags Details
dmesg (39.39 KB, text/plain)
2010-01-09 20:50 EST, António Lima
no flags Details
pm-suspend log (4.05 KB, text/plain)
2010-01-09 20:50 EST, António Lima
no flags Details
messages log (2.08 MB, text/plain)
2010-01-09 20:51 EST, António Lima
no flags Details
xorg log (64.66 KB, text/plain)
2010-01-09 20:52 EST, António Lima
no flags Details

  None (edit)
Description António Lima 2010-01-09 20:49:42 EST
Created attachment 382740 [details]
Xorg.conf

Description of problem: Resume fails after suspend to RAM. Altough I'm using the opensource radeon driver from updates-testing, I never managed to make it work before.


Version-Release number of selected component (if applicable): 0.20.20091221git4b05c47ac.fc12

I'm attaching xorg.conf and system logs.

Please let me know if I can provide more info.
Comment 1 António Lima 2010-01-09 20:50:14 EST
Created attachment 382741 [details]
dmesg
Comment 2 António Lima 2010-01-09 20:50:40 EST
Created attachment 382742 [details]
pm-suspend log
Comment 3 António Lima 2010-01-09 20:51:28 EST
Created attachment 382743 [details]
messages log
Comment 4 António Lima 2010-01-09 20:52:00 EST
Created attachment 382744 [details]
xorg log
Comment 5 Dave Airlie 2010-01-10 03:49:39 EST
why are you running with nomodeset?
Comment 6 António Lima 2010-01-10 06:46:00 EST
Because I'm suffering from bug 498457 which makes my screen go totally black with KMS, the backlight is on but I have no video output.
Comment 7 Dave Airlie 2010-01-14 03:45:19 EST
Can you file a new bug for the kms problem as it wasn't that bug at all, which was nothing to do with your GPU.
Comment 8 António Lima 2010-01-14 09:20:49 EST
I've reported the bug, is bug 554424 . The GPU locks are not happening right now with KMS enabled, as I say in the bug report. Suspend and resume are working properly now with KMS enabled. I'm also using updates-testing which had an update yesterday on xorg-x11-drv-ati
Comment 9 Maxim Burgerhout 2010-01-31 07:52:50 EST
I'm experiencing similar trouble: after seemingly successful suspend, a resume always gives me a black screen. No tty switching possible. CTRL-ALT-DEL lets me reboot though. 

I noticed this at the bottom of pm-suspend.log. Might be the scripts getting killed when I rebooted though:

Sun Jan 31 09:47:22 CET 2010: 
Sun Jan 31 09:47:22 CET 2010: Running hooks for resume
/usr/lib64/pm-utils/sleep.d/99video resume suspend: /usr/lib64/pm-utils/functions: line 39:  2864 Terminated              "${hook}" $2

I've tried updating my kernel to 2.6.32.7-37.fc12.x86_64 from Koji, which does give me brightness controls (finally!) but the resume problem remains. I still need to check whether I can remove acpi_backlight=vendor, which has been in there for weeks from when I tried to get the backlight to work on 2.6.31. 

I also see the lockups when using compositing and KMS. Running with nomodeset now, which fixes the lockups but not the suspend.

I'll try to log in over ssh next time I get either a lockup or an incomplete resume to gather more info.
Comment 10 António Lima 2010-05-30 07:55:40 EDT
This is fixed for me in Fedora 13 with kernel 2.26.33 and with 2.26.34 pulled from rawhide.
Comment 11 Bug Zapper 2010-11-03 21:24:23 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Bug Zapper 2010-12-03 19:38:14 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.