Bug 55421 - nmbd fails to start on s390
Summary: nmbd fails to start on s390
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: s390 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-10-30 22:47 UTC by David Lawrence
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-07 17:08:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2002:022 normal SHIPPED_LIVE New initscripts packages available for Red Hat Linux 7.2 2002-02-06 05:00:00 UTC

Description David Lawrence 2001-10-30 22:47:29 UTC
Description of Problem:
When starting nmbd it exits and generates the following errors in
/var/log/samba/log.nmbd.

[2001/10/30 22:35:45, 0] lib/interface.c:load_interfaces(224)
  WARNING: no network interfaces found
[2001/10/30 22:35:45, 0] nmbd/nmbd_subnetdb.c:create_subnets(242)
  create_subnets: No local interfaces !
[2001/10/30 22:35:45, 0] nmbd/nmbd.c:main(835)
  ERROR: Failed when creating subnet lists. Exiting.
[2001/10/30 22:36:28, 0] nmbd/nmbd_subnetdb.c:create_subnets(242)
  create_subnets: No local interfaces !
[2001/10/30 22:36:28, 0] nmbd/nmbd.c:main(835)
  ERROR: Failed when creating subnet lists. Exiting.

s390's interface is called ctc0 instead of eth0 like Intel. Could that be
causing issues?

Comment 1 Trond Eivind Glomsrxd 2001-11-06 16:04:48 UTC
I'm recompiling samba for s/390 now, in an attempt to fix it.

Comment 2 Trond Eivind Glomsrxd 2001-11-07 17:08:01 UTC
The source doesn't refer to "eth" anyway, I'm pretty certain that's not it.

Comment 3 Trond Eivind Glomsrxd 2001-11-07 20:49:53 UTC
Not a bug in samba - all network interfaces on the S/390 were configured as
point-to-point. Nmbd needs broadcast nics, and exits otherwise - which makes sense

Comment 4 Ngo Than 2001-11-07 21:45:48 UTC
as i have told to you before it's not a bug in samba. It's a bug initscripts.
Now i have finally fixed it. Please update initscripts-6.40-2, it should fix
this problem.


Note You need to log in before you can comment on or make changes to this bug.