Bug 55432 - permission of the directory /usr/include/bonobo should not be set to 0444
permission of the directory /usr/include/bonobo should not be set to 0444
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: bonobo (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-30 21:41 EST by MATSUURA Takanori
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-31 19:47:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MATSUURA Takanori 2001-10-30 21:41:45 EST
Description of Problem:
In the spec file of bonobo-1.0.8-1, the permission of the directory
"%{_includedir}/bonobo" is set to 0444 because of 
%defattr(0444, bin, bin)
%{_includedir}/*

Version-Release number of selected component (if applicable):
1.0.8-1

How Reproducible:
Every time.

Steps to Reproduce:
Normaly build package

Actual Results:
The permission of the directory "%{_includedir}/bonobo" is set to 0444.

Expected Results:
he permission of the directory "%{_includedir}/bonobo" should be set to
0555 or 0755.

Additional Information:
%files devel section should be changed as following:

%files devel
%defattr(-, root, root)
%dir %{_includedir}/bonobo
/usr/lib/*.a
/usr/lib/*.so
/usr/lib/*.sh
/usr/lib/pkgconfig/libefs.pc

%defattr(0444, bin, bin)
%{_includedir}/bonobo/*
%{_includedir}/bonobo.h
Comment 1 Havoc Pennington 2002-02-08 18:23:12 EST
Hmm, apparently fixed in September but bug never closed.

Note You need to log in before you can comment on or make changes to this bug.