Bug 55457 - Kernel Panic on Compaq LTE 5280 (Laptop)
Kernel Panic on Compaq LTE 5280 (Laptop)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 11:54 EST by Thomas Klein
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 05:29:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Klein 2001-10-31 11:54:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
Booting vmlinuz fails with "Kernel panic: Aiee, killing interrupt
handler! In interupt handler - not syncing"

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot "boot.img" from Disk
2. Return (or also text Return)
3. Wait for crash after loading vmlinuz
	

Additional info:
Comment 1 Brent Fox 2001-10-31 19:34:56 EST
On a laptop, you should probably be using the pcmcia.img to boot from.  Does
that avoid the problem?
Comment 2 Thomas Klein 2001-11-01 10:28:09 EST
I tried the installation also with the pcmcia.img, but it showed up the same problem.
Comment 3 Brent Fox 2001-11-01 18:54:46 EST
This seems to be a kernel problem.  Changing component.
Comment 4 Arjan van de Ven 2001-11-02 05:04:37 EST
is there anything before the "aieee" line ?
Comment 5 Thomas Klein 2001-11-05 05:24:29 EST
I do not get always the same messages.
What i get also is "CPU#0: Machine Check Exception: 0x 107000 (type 0x    9)."

Now i have got this (after removing the cdrom drive):
<0>Kernel panic: Attempted to kill the idle task!
In idle task - not syncing

I cannot see all messages because the system hangs after booting and
shift-pageup does not work any more.
Comment 6 Arjan van de Ven 2001-11-05 05:29:17 EST
"CPU#0: Machine Check Exception: 0x 107000 (type 0x    9)." 
usually means that your cpu tells you it's bust ;(
However, some machines have a wiring mistake on the motherboard and trigger this
when there's not really a fault, you can add "nomce" to the kernel commandline
(eg type "linux nomce" on the syslinux prompt) to circumvent this.
Comment 7 Alan Cox 2001-11-05 06:00:02 EST
Compaq 586 laptops show spurious mce's. Boot with "nomce" as a boot option and
it should not show any more strange MCE errors. The "nomce" should not be needed
in the errata kernel either.

Alan
Comment 8 Thomas Klein 2001-11-05 06:36:57 EST
"linux nomce" on the syslinux prompt does help!!!
Now X crashs, but text mode does it.
Thanks for your help.
Comment 9 Alan Cox 2001-11-05 06:39:32 EST
Excellent

If after you grab the kernel errata X still crashes stick in a seperate bug
report for that. 

Note You need to log in before you can comment on or make changes to this bug.