Bug 55465 - tcpdump-3.6.2-9 has endianness problem
tcpdump-3.6.2-9 has endianness problem
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: tcpdump (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 14:02 EST by Olivier Baudron
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-18 15:16:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Baudron 2001-10-31 14:02:53 EST
To reproduce the bug:

# tcpdump -n -s 2000 -X port 67
# dhcpcd -n

The result is:

....LT:1616117760.....
....33 04 00 00 54 60....

The first line is the bootp packet infos shown by tcpdump and the second
line shows the corresponding bytes in the packet.

LT means "lease time"
33 is the option code for lease time
04 is the length of the option
00 00 54 60 is the lease time in seconds (in network byte order)
            i.e: 21600s
But tcpdump says that the lease time is 1616117760 seconds (which is 60 54
00 00 in hexa), so clearly there is an endianness problem somewhere.

I tried tcpdump-3.6.2 from the official website, and it works fine.
So the problem is certainly in redhat's patches.
Comment 1 Olivier Baudron 2001-10-31 14:36:43 EST
I looked in the redhat patches and could not find something wrong.
I tried to rebuild the package, but il fails with:

+ autoconf
configure.in:32: error: AC_LANG: unknown language: 
autoconf/lang.m4:124: _AC_LANG_SET is expanded from...
autoconf/lang.m4:133: AC_LANG is expanded from...
aclocal.m4:713: AC_LBL_LIBRARY_NET is expanded from...
configure.in:32: AC_LBL_LIBRARY_NET is required by...
aclocal.m4:237: AC_LBL_LIBPCAP is expanded from...
configure.in:32: the top level
error: Bad exit status from /var/tmp/rpm-tmp.68583 (%build)
Comment 2 Harald Hoyer 2001-12-18 10:40:57 EST
[root@faro root]# rpm -q tcpdump
tcpdump-3.6.2-9

LT:43200 ... 33 0400 00a8 c0

seems ok to me ...

16:34:00.885609 172.16.2.2.bootps > 255.255.255.255.bootpc:  xid:0x2ade8b46 
secs:3 Y:172.16.2.65 S:172.16.2.140 ether 0:1:2:f1:85:f4 vend-rfc1048 DHCP:ACK 
SID:172.16.2.2 LT:43200 SM:255.255.255.0 DG:172.16.2.254 
NS:172.16.2.2,172.16.2.15 DN:"stuttgart.redhat.com" 
NTP:193.103.254.150,172.16.2.13 (DF)
0x0000   4500 0152 0000 4000 4011 8b89 ac10 0202        E..R..@.@.......
0x0010   ffff ffff 0043 0044 013e 4e71 0201 0600        .....C.D.>Nq....
0x0020   2ade 8b46 0003 0000 0000 0000 ac10 0241        *..F...........A
0x0030   ac10 028c 0000 0000 0001 02f1 85f4 0000        ................
0x0040   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0050   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0060   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0070   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0080   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0090   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00a0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00b0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00c0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00d0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00e0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x00f0   0000 0000 0000 0000 0000 0000 0000 0000        ................
0x0100   0000 0000 0000 0000 6382 5363 3501 0536        ........c.Sc5..6
0x0110   04ac 1002 0233 0400 00a8 c001 04ff ffff        .....3..........
0x0120   0003 04ac 1002 fe06 08ac 1002 02ac 1002        ................
0x0130   0f0f 1473 7475 7474 6761 7274 2e72 6564        ...stuttgart.red
0x0140   6861 742e 636f 6d2a 08c1 67fe 96ac 1002        hat.com*..g.....
0x0150   0dff



Comment 3 Olivier Baudron 2001-12-18 15:16:26 EST
Ahemmm... now it works also on my computer (up-to-date with rawhide).
I probably made a mistake somewhere...
Sorry.

Note You need to log in before you can comment on or make changes to this bug.