Bug 55470 - 3rd PCI bus not seen on 2.4.9
3rd PCI bus not seen on 2.4.9
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 14:31 EST by Patrick C. F. Ernzer
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-25 08:02:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/proc/cpuinfo (756 bytes, text/plain)
2001-10-31 14:33 EST, Patrick C. F. Ernzer
no flags Details
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.7-10smp (15.89 KB, text/plain)
2001-10-31 14:35 EST, Patrick C. F. Ernzer
no flags Details
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.9-7smp (15.08 KB, text/plain)
2001-10-31 14:36 EST, Patrick C. F. Ernzer
no flags Details
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.13-0.5 (16.43 KB, text/plain)
2001-11-07 08:56 EST, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2001-10-31 14:31:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
on a Transtec 4100 dual Pentium III 550, I do not see the third PCI bus on
2.4.9-7smp but it is visible under 2.4.7-10smp.

Nothing except the kernel changed on the machine.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot 2.4.9-7smp
2. network card on third PCI bus is not visible
3. boot 2.4.7-10smp
4. network card on third PCI bus is visible
	

Additional info:

the network card is the only device on the third PCI bus.
Comment 1 Patrick C. F. Ernzer 2001-10-31 14:33:50 EST
Created attachment 35902 [details]
/proc/cpuinfo
Comment 2 Patrick C. F. Ernzer 2001-10-31 14:35:11 EST
Created attachment 35903 [details]
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.7-10smp
Comment 3 Patrick C. F. Ernzer 2001-10-31 14:36:12 EST
Created attachment 35904 [details]
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.9-7smp
Comment 4 Arjan van de Ven 2001-10-31 14:54:13 EST
Known problem known cause
will be fixed in rawhide soon
Comment 5 Patrick C. F. Ernzer 2001-11-07 08:56:32 EST
kernel-enterprise-2.4.13-0.5 from rawhide fixes the problem for me.
Comment 6 Patrick C. F. Ernzer 2001-11-07 08:56:46 EST
Created attachment 36766 [details]
uname -a, lspci -vvv, dmesg and /proc/interrupts under 2.4.13-0.5
Comment 7 Patrick C. F. Ernzer 2001-11-07 09:03:27 EST
kernel-smp-2.4.13-0.5 from rawhide works as well.
Comment 8 Patrick C. F. Ernzer 2002-01-25 07:51:43 EST
This seems to be also fixed out of rawhide.

The problem does not surface on the following (oficially released) Red Hat
kernels  on the machine I ran tests on:

kernel-2.4.9-21
kernel-smp-2.4.9-21
kernel-enterprise-2.4.9-21

Thanks for the good work.

(It may be useful to change the status from closed rawhide to fixed)
Comment 9 Arjan van de Ven 2002-01-25 08:02:15 EST
Excellent!

Note You need to log in before you can comment on or make changes to this bug.