Bug 55486 - Installer exits abnormally after formatting partitions on Digital Celebris system.
Installer exits abnormally after formatting partitions on Digital Celebris sy...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 37592 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-31 21:04 EST by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-09 11:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install messages from virtual consoles (5.15 KB, text/plain)
2001-10-31 21:07 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-10-31 21:04:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
 I am unable to install RH 7.2 on a Digital Celebris 6180
        Pentium Pro 180 MHz
        Phoenix BIOS 4.05
        Digital System BIOS 1.08
        Integrated:
                            Ethernet
                            USB
                            Matrox Millineum 2 Meg Video
                            Sound
                            IDE/Floppy Controler

I initially ran the "Upgrade System" option in the install program.  After
selecting all of the options, the program upgraded my file systems on all
partitions to ext3, then became very sluggish when "Copying install image
to hard drive," and "Preparing RPM Transaction."  Then, was also sluggish
when "Preparing to install."  The progress bar never reached past approx.
1/4 to 1/3 of the way in "Preparing to install" before system spontaneously
rebooted.  I tried this twice w/ the same results.

Next I attempted a fresh install without reformating my /home partition. 
After selecting all of the options, the program quickly formatted my / and
/boot partitions, then kicked out of the graphical install without
proceeding to the next phase, and reports "install exited abnormally" and
the OS goes into shutdown mode.  Messages on the virtual consoles is attached.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run installer on Digital Celebris system
2.Choose any combination of install options
3.
	

Actual Results:  When using the "upgrade" option, install becomes slugish
during "copying install image" and "preparing RPM transaction" and reboots
during "preparing to install"

When using the "install" option, install kicks out of graphical install
after formatting partitions, then shuts down the system reporting "install
exited abnormally"

Expected Results:  Install should proceed to installation of packages and
post install details.

Additional info:

I have tried the install proceedure on two Digital Celebris 6180 systems
with completely different hardware with identical results.

RH 7.0 Install worked perfectly for these systems, and all of the
components were automatically configured and worked perfectly w/ Linux (RH
7.0)
Comment 1 Need Real Name 2001-10-31 21:07:34 EST
Created attachment 35941 [details]
Install messages from virtual consoles
Comment 2 Brent Fox 2001-11-01 17:27:47 EST
We have had a number of reports for Digital Celebris machines, but we didn't
have one in order to do the testing.  A friend at Compaq graciously sent us one
two days ago so we could work on it.  I've put together an updates disk that
should allow you to work around the problem.  It is available at:

ftp://people.redhat.com/bfox/7.2-celebris-quickfix.img

Download this file and dd it to a floppy.  Then boot the 7.2 installer with the
'linux updates' command.  Insert the updates floppy when prompted.  Does this
fix the problem?
Comment 3 Need Real Name 2001-11-09 11:02:15 EST
Yes, the updates disk does the trick.  After using it, the installer works
great.  I have experienced some flaky reboots, but they are not reproducible,
and I believe they are hardware related (either memory or interference from the
monitor).  My only issue with the system now involves DHCP with my ADSL
supplier.  Again, this worked on the Digital Celebris with a RH 7.0 install, and
is working with a white box with RH 7.2 install and a 3-Com card.  I belive this
is a separate bug (mabye w/ Tulip driver?) or even just a config problem.  Could
you give me some guidance about whether I shoud open a new service request/bug
report, or continue to work it with you through this bug report?  Here is the
relevant info from /var/log/messages for reference, and the ethernet hardware
info from /etc/sysconfig/hwconf

class: NETWORK
bus: PCI
detached: 0
device: eth
driver: tulip
desc: "DEC|DECchip 21142/43"
vendorId: 1011
deviceId: 0019
subVendorId: 0000
subDeviceId: 0000
pciType: 1

Nov  5 01:57:59 localhost sysctl: net.ipv4.ip_forward = 0 
Nov  5 01:57:59 localhost sysctl: net.ipv4.conf.default.rp_filter = 1 
Nov  5 01:57:59 localhost sysctl: kernel.sysrq = 0 
Nov  5 01:57:59 localhost network: Setting network parameters:  succeeded 
Nov  5 01:58:00 localhost network: Bringing up interface lo:  succeeded 
Nov  5 01:58:01 localhost ifup: Determining IP information for eth0... 
Nov  5 01:59:05 localhost kernel: ip_conntrack (512 buckets, 4096 max)
Nov  5 01:59:05 localhost kernel: Linux Tulip driver version 0.9.15-pre6 (July
2, 2001)
Nov  5 01:59:05 localhost kernel: tulip0:  EEPROM default media type Autosense.
Nov  5 01:59:05 localhost kernel: tulip0:  Index #0 - Media 10baseT (#0)
described by a 21142 Serial PHY (2) block.
Nov  5 01:59:05 localhost kernel: tulip0:  Index #1 - Media 10baseT-FDX (#4)
described by a 21142 Serial PHY (2) block.
Nov  5 01:59:05 localhost kernel: tulip0:  Index #2 - Media 10base2 (#1)
described by a 21142 Serial PHY (2) block.
Nov  5 01:59:05 localhost kernel: tulip0:  Index #3 - Media AUI (#2) described
by a 21142 Serial PHY (2) block.
Nov  5 01:59:05 localhost kernel: tulip0:  Index #4 - Media MII (#11) described
by a 21142 MII PHY (3) block.
Nov  5 01:59:05 localhost kernel: tulip0: ***WARNING***: No MII transceiver found!
Nov  5 01:59:05 localhost kernel: eth0: Digital DS21143 Tulip rev 48 at
0xc4873c00, 00:00:F8:79:4C:E1, IRQ 9.
Nov  5 01:59:01 localhost dhcpcd[607]: timed out waiting for a valid DHCP server
response  
Nov  5 01:59:01 localhost ifup:  failed. 
Nov  5 01:59:01 localhost network: Bringing up interface eth0:  failed
Comment 4 Brent Fox 2001-11-09 16:27:09 EST
I would recommend filing a new bug report against iputils.
Comment 5 Jeremy Katz 2002-03-26 19:15:28 EST
*** Bug 37592 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.