Bug 55493 - text output appears twice
text output appears twice
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 00:35 EST by Curtis Doty
Modified: 2015-01-07 18:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-06 19:05:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Curtis Doty 2001-11-01 00:35:25 EST
I dunno if this is related to 55492 or not...but I've also run into this 
symtom of progress hashing appearing twice:

# up2date -dv foomatic ghostscript pam pam-devel printconf printconf-gui

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
The following packages were added to your selection to satify dependencies:

Name                                    Version        Release
--------------------------------------------------------------
Omni                                    0.5.0          4                   
Omni-foomatic                           0.5.0          4                   

Retrieving selected packages...
foomatic-1.1-0.20011018.3.i ########################## 
Done.                   
########################## Done.                   
ghostscript-6.51-16.i386.rp ########################## 
Done.                   
########################## Done.                   
pam-0.75-16.i386.rpm:       ########################## 
Done.                   
########################## Done.                   
pam-devel-0.75-16.i386.rpm: ########################## 
Done.                   
########################## Done.                   
printconf-0.3.52-1.i386.rpm ########################## 
Done.                   
########################## Done.                   
printconf-gui-0.3.52-1.i386 ########################## 
Done.                   
########################## Done.                   
Omni-0.5.0-4.i386.rpm:      ########################## 
Done.                   
########################## Done.                   
Omni-foomatic-0.5.0-4.i386. ########################## 
Done.                   
########################## Done.

Is something screwey with the progressCallback?

../C
Comment 1 Adrian Likins 2001-11-01 16:26:41 EST
If you have the system configured to download source rpms as well, you
will see two download hash bars.

I'll take a look at the text mode progress callbacks and make sure they
are doing the right thing.
Comment 2 Curtis Doty 2001-12-05 01:43:01 EST
I'm not downloading any srpms.

But it looks like 2.7.11-7.x.2 fixes the problem on 7.2. Thanks!

However, with the new release I now noticed double hashing on a different box 
running 7.1. ;)

Just the first prompt...the one that goes:

Retrieving list of all available packages...
########################################
########################################

The rest behave properly.

../C
Comment 3 Curtis Doty 2001-12-05 01:47:23 EST
I may not have been clear...so here's what I saw on 7.1 box...

# up2date -iv up2date                          

Retrieving list of all available packages...

Removing installed packages from list of updates...
########################################

Removing packages with files not specified from list...

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Testing package set / solving RPM inter-dependencies...
########################################
The following packages were added to your selection to satify dependencies:

Name                                    Version        Release
--------------------------------------------------------------
python-popt                             0.6            4                   
python-xmlrpc                           1.5.1          7.x.3               

Retrieving selected packages...
up2date:                    ########################## Done.                   
python-popt:                ########################## Done.                   
python-xmlrpc:              ########################## Done.                   
Preparing...                ########################################### [100%]
   1:python-popt            ########################################### [ 33%]
   2:python-xmlrpc          ########################################### [ 66%]
warning: /etc/sysconfig/rhn/up2date created as /etc/sysconfig/rhn/up2date.rpmnew
   3:up2date                ########################################### [100%]
# up2date -l

Retrieving list of all available packages...
########################################
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...
########################################

Removing packages with files marked to skip from list...
########################################

Name                                Version        Rel     
---------------------------------------------------------
apache                                  1.3.22         1.7.1               
apache-manual                           1.3.22         1.7.1               
kernel                                  2.4.9          12                  
openssh                                 2.9p2          11.7                
openssh-askpass                         2.9p2          11.7                
openssh-askpass-gnome                   2.9p2          11.7                
openssh-clients                         2.9p2          11.7                
openssh-server                          2.9p2          11.7                
rhn_register                          2.7.2          7.x.8               
sendmail                                8.11.6         2.7.1               

# rpm -q up2date
up2date-2.7.11-7.x.1

Note the second row of hashes appears after upgrading. Persnickety, huh.
Comment 4 Adrian Likins 2002-03-06 19:05:34 EST
There is one hash bar per channel in that case. (you
are downloading two package lists).

yeah, that kind of disagrees with the behaviour you
would expect based on the wording. I'll see if
I can munge the progress outputs together (or
perhaps just change the wording ;->)

Note You need to log in before you can comment on or make changes to this bug.