Bug 55505 - Do not allow required packages (like kudzu) to be unselected
Do not allow required packages (like kudzu) to be unselected
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 56378 57085 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 09:48 EST by manuel wolfshant
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-21 19:50:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description manuel wolfshant 2001-11-01 09:48:11 EST
Description of Problem:
installer crashes after all packages have been copied to hard disk if kudzu
is not selected

Version-Release number of selected component (if applicable):


How Reproducible:
only tried once, but the error is quite clear

Steps to Reproduce:
1. select desired packages
2. unselect kudzu from the "flat view" of the packages
3. accept installing all dependencies
4. go to install

Actual Results:
installer crashes with "unhandled exception". mouse is no longer
functional, but switching consoles (Alt-F1) shows a traceback which ends
with:
File "/usr/lib/anaconda/iutil.py", line 61m in execWithRedirect raise
RuntimeError, command + " can not be run"
Runtime Error: /usr/sbin/kudzu can not be run

Expected Results:
instalation should have continued ...

Additional Information:
Comment 1 Bill Nottingham 2001-11-01 11:52:57 EST
Note that if running kudzu in the post-install fails, or is not done, any HW not
configured by the install will remain unconfigured.
Comment 2 manuel wolfshant 2001-11-02 03:42:01 EST
Not only that hardware is not configured but even doing an 'upgrade' install
over the crashed one will not fix the problem(s). Kudzu will NOT be
automatically selected in the list of packages to be added (actually no package
was autoselected), and even after manually adding it, the end result of the
instalation is non functional. In my case, lilo was not run and I ended up with
the lilo configuration from the previous (RH 7.1) lilo configuration, which was
not valid any more, since the partition was formatted.
Additional data: I did NOT choose to use grub, sticking to the good old lilo.

Last minute idea: maybe forcing reinstall of lilo would have been kind of a fix
?
Comment 3 Brent Fox 2001-11-08 22:21:59 EST
Well, the short answer is that you should pretty much always install kudzu.  If
you don't the hardware on the system will not be detected.  The reason that the
upgrade failed is that you were trying to do something that upgrades were not
designed to do.  You were trying to do more of a rescue than an upgrade, which
isn't going to work.  When the installer saw that the installed version of lilo
installed was the same as the version on the cd, then the installer didn't try
to upgrade a version to the same version.

Kudzu is part of the base Red Hat Linux installation.  The user removes packages
from base at their own risk.  Don't be surprised if things fail if you unselect
packages from base.
Comment 4 manuel wolfshant 2001-11-09 04:07:53 EST
Well, I _KNOW_ what hardware is in my router and _I_do_not_need_ it installed.
And if it is needed by the installer, then I think it should have complained
after verifying the dependencies
And last.. there is no documentation anywhere stating that installing kudzu is
mandatory
Comment 5 Brent Fox 2001-11-09 15:48:12 EST
Ok.  Reopening.
Comment 6 Brent Fox 2002-01-20 23:29:11 EST
*** Bug 57085 has been marked as a duplicate of this bug. ***
Comment 7 Brent Fox 2002-01-20 23:30:00 EST
*** Bug 56378 has been marked as a duplicate of this bug. ***
Comment 8 Sean M Lentner 2002-01-21 02:04:55 EST
I had the same problem and I opened bug # 57085 which is a dup of this issue.  
What I found was it didn't complain about kudzu and I also noticed that when it 
resolved dependencies after unchecking kudzu it wouldn't find any dependencies
even though there were still a few packages I didn't resolve manually by going 
back and unchecking them in the flat view required.

1. Uncheck a package that has a dependency
2. run the dependencies checker
3. Go back into the flat view and uncheck kudzu & kudzu dependent
4. run the dependencies checker
There you go, no more dependencies, even though there still are...
I was told the ISO I DL from redhat.com was corrupted maybe maybe not, still 
worth checking out?
Comment 9 Jeremy Katz 2002-03-21 19:50:25 EST
Fixed in CVS

Note You need to log in before you can comment on or make changes to this bug.