Bug 555061 - apps killed in gnome-terminal continue to run and go to 100% of cpu
apps killed in gnome-terminal continue to run and go to 100% of cpu
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-13 10:02 EST by pleabargain
Modified: 2010-04-13 10:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 10:18:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pleabargain 2010-01-13 10:02:32 EST
[user@localhost ~]$ uname -r
2.6.31.9-174.fc12.i686
[user@localhost ~]$ rpm -qa gnome-terminal
gnome-terminal-2.28.2-1.fc12.i686




Description of problem:
Twice today I went to su.
I ran system-network-config
later one of my dual cores went to 100%
I 'top'ped and found system-network-config was still running even though I'd killed the terminal

later
running iptraf as root
later one of my dual cores went to 100%
I 'top'ped and found iptraf was still running even though I'd killed the terminal


 

Version-Release number of selected component (if applicable):
[user@localhost ~]$ uname -r
2.6.31.9-174.fc12.i686
[user@localhost ~]$ rpm -qa gnome-terminal
gnome-terminal-2.28.2-1.fc12.i686


How reproducible:
Not always

Steps to Reproduce:
start a terminal
go to su
1.start an app that has a cell based UI 
2.use it
3.stop it
kill the terminal
 wait
 (it doesn't always happen)
Comment 1 pleabargain 2010-01-14 12:37:04 EST
Another instance of gnome terminal after death still having a process running:
http://sites.google.com/site/anotherfedora12site/fedora-12-animated-gifs/iptraf100percentofcpuafterkillingterminal.gif?attredirects=0
Comment 2 pleabargain 2010-04-13 10:18:10 EDT
Not happened in awhile marking as works for me.

Note You need to log in before you can comment on or make changes to this bug.