Bug 55526 - w3c-libwww has bad rpaths
Summary: w3c-libwww has bad rpaths
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: w3c-libwww   
(Show other bugs)
Version: 7.3
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-01 17:01 UTC by Tim Powers
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-10 15:25:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Powers 2001-11-01 17:01:07 UTC
++++++++++ w3c-libwww-apps-5.2.8-10.ia64.rpm ++++++++++
E: w3c-libwww-apps binary-or-shlib-defines-rpath /usr/bin/w3c
['/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/Library/src/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/expat/xmlparse/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/expat/xmltok/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/md5/.libs']
E: w3c-libwww-apps binary-or-shlib-defines-rpath /usr/bin/webbot
['/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/Library/src/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/expat/xmlparse/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/expat/xmltok/.libs',
'/usr/src/build/37123-ia64/BUILD/w3c-libwww-5.2.8/modules/md5/.libs']

Comment 1 Harald Hoyer 2001-12-13 14:42:12 UTC
?????

bash-2.05$ rpmlint 
/mnt/md1/redhat/beehive/comps/dist/7.2/w3c-libwww/5.2.8-10/ia64/w3c-libwww-apps-5.2.8-10.ia64.rpm
W: w3c-libwww-apps invalid-license W3C (see: 
http://www.w3.org/Consortium/Legal/copyright-software.html)


Comment 2 Tim Powers 2001-12-13 16:33:11 UTC
This is wierd. It no longer shows up when rpmlint is run on it, but the paths
are there if you check the strings in the two apps. The problem isn't that it
defines an rpath, it's that it defines an rpath from the buildroot on the
buildmachine.

Tim

Comment 3 Mike McLean 2003-01-02 19:44:39 UTC
Looks like this shouldn't be marked as MODIFIED.  Changing to ASSIGNED.


Note You need to log in before you can comment on or make changes to this bug.