Bug 55538 - snmpd fails if
snmpd fails if
Status: CLOSED DUPLICATE of bug 55840
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-11-01 13:55 EST by kevin_myer
Modified: 2015-03-04 20:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-08 05:41:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description kevin_myer 2001-11-01 13:55:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5) Gecko/20011012

Description of problem:
snmpd fails to start if you use the disk config option in
/etc/snmp/snmpd.conf to monitor disk usage.  Specifically, with a line like:

disk / 10%
(or disk / 100000 )

in the config file, ucd-snmp fails to start.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
2.ps auxw | grep snmpd

Actual Results:  nothing.  strace shows snmpd dying after reading the
config file.  Selectively disabling options in the config file led me to
find that it was the disk option that was causing it to fail.

Expected Results:  snmpd should start

Additional info:

I have verified this on two different machines that I upgraded to Red Hat
7.2.  Both are using ext3.  ucd-snmp-4.2.1-8 (from RawHide) continues to
work on another machine I have that is still running Red Hat 7.1 but is
also running ext3 (w/ kernel 2.4.7-6).
Comment 1 Hal Roberts 2001-11-01 15:49:00 EST
I independently came to the same conclusion and cam here to report it.  If you
put any sort of "disk" directive in snmpd.conf, snmpd will fail to start.
Comment 2 Hal Roberts 2001-11-01 15:57:09 EST
The 4.2.2 rpms at http://sourceforge.net/project/showfiles.php?group_id=12694
solve the problem.
Comment 3 alex kramarov 2001-11-02 16:03:36 EST
Well, i have also ran into this bug, and too bad it's on my production servers. 
will try the http://sourceforge.net/project/showfiles.php?group_id=12694
Comment 4 Libor Pechacek 2001-11-08 05:41:45 EST
Recompiling the package from source RPM helped me.  I was about to hunt down 
the problem and it silently disappeared.  Probably it was result of applying 
available updates (namely glibc).

Name        : ucd-snmp                     
Version     : 4.2.1                             
Release     : 7                             
Build Date: Thu 08 Nov 2001 11:23:22 AM CET
Install date: Thu 08 Nov 2001 11:23:49 AM CET      
Build Host: trinity.clnet.cz
Source RPM: ucd-snmp-4.2.1-7.src.rpm
Size        : 2764707                 
Comment 5 Phil Knirsch 2001-11-12 06:25:56 EST

*** This bug has been marked as a duplicate of 55840 ***

Note You need to log in before you can comment on or make changes to this bug.