Bug 55542 - dot files not hidden
dot files not hidden
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 14:38 EST by Michal Jaegermann
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-03 14:04:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-11-01 14:38:06 EST
Description of Problem:
With samba-2.0.10-2 (the last one from updates to RH 7.1) I have
"hide dot files=Yes", which is confirmed by 'testparm', but on a client
all these dot files do show up - at least in a "[Homes]" share.
Cosmetic but the real user of this client is tad confused.
Comment 1 giulioo 2001-11-03 13:46:13 EST
With "hide dot files" dot files are served as "hidden", this means the win 
client may or may not show them to the user, depending on how it's confgured 
(explorer, view, folder option, ..).

I think you want "veto files": files in this list will not be served at all.

veto files = /.*/
Comment 2 Michal Jaegermann 2001-11-03 14:03:12 EST
Re-reading 'man smb.conf' I do not think that I would really want "veto files".
A number of possible side-effects, including but not limited to performance
impact, is too great.  "Hide dot files" _should_ be it.
 
OTOH maybe the problem is really on a client side and its file browser
configuration?  Looking at the manual closer Samba does not really "hides"
these files but is only setting an attribute "hidden".  As this is not on my
client and/or network I will likely be able to check that only in few days.
My meagre knowledge of Windows is possibly showing. :-)
Comment 3 Trond Eivind Glomsrxd 2001-11-06 14:34:23 EST
As long as the proper attribute is set, this is a windows filebrowser
configuration issue. Closing.

Note You need to log in before you can comment on or make changes to this bug.