Bug 55549 - anaconda crashing on multiple ethernet devices
Summary: anaconda crashing on multiple ethernet devices
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 58508 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-11-01 21:08 UTC by Dean Oliver
Modified: 2007-04-18 16:37 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:48:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dean Oliver 2001-11-01 21:08:14 UTC
Description of Problem:


Anaconda will crash when multiple ehternet devices are in the system. 12 or more will cause the crash, whether dual port or single port. This was tested with intel chipset nics.


diamond, merlot





Version-Release number of selected component (if applicable):


redhat 7.2 gold2





How Reproducible:


everytime





Steps to Reproduce:


1. install 6 or more dual ports nics, or a combination with single port nics to bring the total ports to 12 or more, this includes any onboard nics.


2. 


3. 





Actual Results:








Expected Results:








Additional Information:

Comment 1 Bill Nottingham 2001-11-01 21:20:01 UTC
The crash is apparently after loading thje eepro100 module.

Comment 2 John A. Hull 2001-11-01 22:57:52 UTC
occurs on PowerEdge 8450 and new 6600 and 4600.

Performed an expert noprobe and specified the e100 module. Install crashed with 
this as well.

Comment 3 Dean Oliver 2001-11-01 23:33:58 UTC
On virtual console 3 the last statement shown is:
going to insmod eepro100. All ethernet devices are probed and listed before this.
Using combinations with other manufacturers nics allows the # of nic ports to exceed 11, Have successfully ran with 5 dual port intel, 1 single intel, 3 broadcom 5701.


Comment 4 Jeremy Katz 2001-11-02 21:09:33 UTC
Just to clarify -- you're saying that this only happens if it's twelve or more
eepro100s?

Arjan -- do you have any ideas here?

Comment 5 Michael E Brown 2001-11-02 21:14:32 UTC
It may be 12 or more of any single device, we don't know, because the only
dual-port cards we have are Intel. We've tried both e100 and eepro100 drivers,
so it seems unlikely to be just Intel cards, more likely to be an installer problem.

Comment 6 Michael Fulbright 2002-01-15 21:58:33 UTC
This is in text mode only?

Comment 7 Michael E Brown 2002-01-17 18:38:40 UTC
It crashes before getting to graphical mode.

Comment 8 Michael Fulbright 2002-01-21 19:57:04 UTC
*** Bug 58508 has been marked as a duplicate of this bug. ***

Comment 9 Mike Snitzer 2002-02-04 20:11:10 UTC
I am attempting to do a 7.2 kickstart upgrade on Dell 1550, 1650, 2450, 2550
(all have multiple, 2 or 3,  onboard nics (eepro100, broadcom, or e1000).  As
soon as the /sbin/loader starts; the installer exists with:

"install exited abnormally -- recieved signal 11"

It is imperative I get anaconda to function on these Dell systems... has anyone
made any progress on this issue?  It would appear to be > 12 nic independent.

Please advise,

Mike Snitzer
msnitzer@plogic.com

Comment 10 Michael Fulbright 2002-02-13 19:42:46 UTC
I do not have access to this type of hardware - if Dell can provide a system
with the required networking adapters we can proceed on this issue.

Comment 11 Michael E Brown 2002-02-22 21:49:36 UTC
7 dual-port intel nics should be in your lap sometime next week.

Comment 12 Michael Fulbright 2002-02-26 17:53:13 UTC
Got the cards, I see the problem and I hope to have a fix in CVS today.

Thanks for sending the cards, it makes all the difference on these types of issues.

Comment 13 Michael Fulbright 2002-02-27 18:02:24 UTC
I have this fixed, needs testing in next internal tree.

Comment 14 Michael Fulbright 2002-02-27 19:41:24 UTC
Tested to work.

Comment 15 Red Hat Bugzilla 2006-02-21 18:48:13 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.