Bug 55567 - up2date crashes when running update
up2date crashes when running update
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-01 23:39 EST by Steve Wardell
Modified: 2015-01-07 18:52 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-03 18:42:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wardell 2001-11-01 23:39:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
When I run up2date to up2date or list available packages, it crashes. I 
previously used up2date after installing 7.2 and it worked fine. It 
displays the following, then exits:

Retrieving list of all available packages...
########################################

Removing installed packages from list of updates...
########################################

Removing packages marked to skip from list...
########################################

Getting headers for available packages...

Here is an excert from my up2date log:


[Thu Nov  1 23:34:33 2001]   File "/usr/sbin/up2date", line 996, in ?
    main()
   File "/usr/sbin/up2date", line 342, in main
    sys.exit(batchRun(argObj.getLong("list"), pkgNames, fullUpdate))
   File "/usr/sbin/up2date", line 879, in batchRun
    printCallback, percentCallback)
   File "/usr/sbin/up2date", line 792, in runInteractive
    progressCallback = percentCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 1539, in 
getUpdatedPack
ageList
    refreshCallback)
   File "/usr/share/rhn/up2date_client/up2date.py", line 801, in getHeaders
    progressCallback(len(headerList), total)
   File "/usr/sbin/up2date", line 394, in percent
    up2date.log.trace_me()
   File "/usr/share/rhn/up2date_client/up2date.py", line 89, in trace_me
    x = traceback.extract_stack()


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run up2date -l or up2date -u
2. Program gets to: Getting headers for available packages...

	

Actual Results:  Program crashes, thou with no error message.

Expected Results:  Program would retrieve list of available packages.

Additional info:

When I installed 7.2 on this system, I formatted all but the home 
partitions so install should be clean.
Comment 1 Adrian Likins 2001-11-02 14:22:50 EST
The stack trace in the log file is from a rogue debugging statement.
The application isnt actually crashing, but is dumping a stack trace
of the utility at some point in the program without actually crashing.

The next version of the client will have this debugging statement removed.
Comment 2 Steve Wardell 2001-11-02 15:10:21 EST
So the program is exiting and that's why it doesn't finish the update? Is there 
a workaround so my update will complete? When is the next version due and will 
this fix my issue?
Comment 3 Peter E. Popovich 2001-11-02 17:50:34 EST
the log file is indeed a red herring.

retreiveOnly is turned on by default in up2date-2.7.2-7.x.6. because of this, 
rpm files are transferred, but not installed. running up2date-config and 
turning off retreiveOnly, will allow up2date to apply transfers.

i'm betting i'm not the only one with keyboard dents in his forehead over this.
Comment 4 Steve Wardell 2001-11-03 12:02:55 EST
It was turned off. However, once I removed the files in the /var/spool/up2date/ 
and reran the program, it seemed to work ok now.
Comment 5 Behdad Esfahbod 2002-01-03 18:42:01 EST
I had the same problem, the backtrace from the core I once got, showed that the 
fault is from librpm in function rpm_header()..., I just did 'rm -
f /var/spool/up2date' and everything worked fine :-).
Comment 6 David M. Cook 2002-02-22 12:26:59 EST
Fix: http://www.redhat.com/support/errata/RHBA-2001-119.html

Note You need to log in before you can comment on or make changes to this bug.