This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 55579 - doesn't understand the LABEL= directive in /etc/fstab
doesn't understand the LABEL= directive in /etc/fstab
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
7.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 07:11 EST by Alan Hourihane
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Hourihane 2001-11-02 07:11:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
When quitting linuxconf, it always asks you to re-mount any filesystems 
with the LABEL= prefix as it appears that LinuxConf doesn't understand 
them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. edit /etc/fstab with a LABEL= directive
2. run 'linuxconf'
3. quit 'linuxconf'
	

Actual Results:  Directory / was mounted on /dev/sda1, should be LABEL=/
   Executing: /bin/umount /
   Executing: /bin/mount -t ext3 -o exec,dev,suid,rw -L / /


Expected Results:  Linuxconf should just quit gracefully.

Additional info:
Comment 1 Christian Jacobsen 2002-05-23 05:28:54 EDT
I have got the same problem.

What tool can I use for Text-only configuration ? Ist there an better tool ?

Server Compaq ML370, Onboard Array Controler, RH 7.2 minimum install with EXT3 
Filessystem.


/etc/fstab :

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/boot             /boot                   ext3    defaults        1 2
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
LABEL=/var              /var                    ext3    defaults        1 2
/dev/ida/c0d0p2         swap                    swap    defaults        0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0
0
/dev/fd0                /mnt/floppy             auto    noauto,owner,kudzu 0 0



Output from linuxconf on exit :

 Directory / was mounted on /dev/ida/c0d0p6, should be LABEL=/            
       Executing: /bin/umount /                                            
       Executing: /bin/mount -t ext3  -o exec,dev,suid,rw -L / /           
  Directory /boot was mounted on /dev/ida/c0d0p1, should be LABEL=/boot    
       Executing: /bin/umount /boot                                        
       Executing: /bin/mount -t ext3  -o exec,dev,suid,rw -L /boot /boot   
  Directory /var was mounted on /dev/ida/c0d0p5, should be LABEL=/var      
       Executing: /bin/umount /var                                         
       Executing: /bin/mount -t ext3  -o exec,dev,suid,rw -L /var /var     
       Changing permissions  of file /etc/shadow from 100400 to 100600     
Comment 2 Brent Fox 2002-06-05 12:14:33 EDT
Closing because we don't ship linuxconf anymore
Comment 3 Red Hat Bugzilla 2006-02-21 13:48:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.