Bug 55584 - RP3 only shows user ppp0 not the name of the isp link
RP3 only shows user ppp0 not the name of the isp link
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
7.2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 09:57 EST by Clark Tompsett
Modified: 2007-04-18 12:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 10:19:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Tompsett 2001-11-02 09:57:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (Win98; U)

Description of problem:
I had to do a fresh install of RH 7.2.  As root, rp3 works correctly providing the name of the dial up link.  Logging in as a user and trying to 
start rp3 results in a selection of : ppp0, ethernet and loopback.  Selecting ppp0 results in rp3 going directly to ppp0 but never dialing the 
modem.  
This did not occur with RH 7.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH 7.2
2. As root setup you dial up account
3. Start rp3, it will give you the names of the isp's that you setup and correctly dial the account
4. log out and then back in as user
5. start rp3
6 rp3 will only list ppp0 to pppn (dependent on number of dial up accounts)
7 selecting pppn results in ppp0 being shown but wvdial is never called to dial modem.
8 open terminal window 
9 su and password
10. start rp3
11.  rp3 now list the accounts that were setup, will dial and connect correctly
12 user now able to use dial up account(s)
	

Actual Results:  rp3 works as root but fails under user login

Expected Results:  under a user login, rp3 should have presented list of the dial up accounts, allowed the user to select an account, 
dialed 
out and connected.

Additional info:
Comment 1 Need Real Name 2001-11-12 14:48:09 EST
as has been business as usual in every version of rp3 since it's introduction,
rp3 once again is totally a pain in the ass!!

i was just able to resolve it this way: when creating an account, let's call it
"isp-work", choose "default modem" and click the "allow users to start and
stop". i then added the rp3 applet to my panel and it allowed me to choose my
new "isp-work" account. i clicked the green button and it dialed.

it doesn't work with my eth0 though...
Comment 2 Need Real Name 2001-11-12 15:05:22 EST
i forgot, also click the "make this connection default route".
Comment 3 Need Real Name 2001-11-12 15:35:03 EST
in clark's original bug report, step 2 says to create an account as root, but it
doesn't say how... i am guessing he set it up with internet-druid??? as i stated
in my previous post, i was able to get everything working great, i wanted to try
and get the ethernet working so i could bring it up and down with the rp3
applet, after checking the "allow users..." option i saved it and exited and
then the rp3 applets i had just created all crashed. the accounts i had created
with rp3-config were no longer available. i deleted everything from started over
using only rp3-config and all is well.

so i am guessing that rp3 & rp3-config actually are fine, it is when you create
accounts with internet-druid and try to dial them with the rp3 applet that you
get into trouble. it think...
Comment 4 Clark Tompsett 2001-11-12 15:46:41 EST
I orginially tried using the 'new' internet setup tool.  When that failed, I 
went back to the setup routine in rp3-config.  As root, I can start rp3 and
select the isp that I want to use.  Logging in as a user, I only get ppp0, eth0,
and loopback.  Selecting ppp0 only brings up a connection window with out
dialing the modem.
Comment 5 Clark Tompsett 2001-11-12 16:20:16 EST
After deleting wvdial.conf and recreating it using rp3-conf, users can now dial
the accounts.  It looks that 'neat' and the new internet dialer setup are
causing the problems.
Comment 6 Need Real Name 2001-12-24 02:01:37 EST
I tried the method suggested by clarkt@cnsp.com, and it worked.
Comment 7 Smiley Ben 2001-12-24 07:16:13 EST
Curious. That works for me too, thanks! But that's really quite silly....
Comment 8 Weiqi Gao 2002-03-07 07:42:56 EST
[This is one post in a thread on the St. Louis Unix User's Group
(http://www.sluug.org) discuss mailing list discussing the same bug.]

> I had to chmod 644 /etc/sysconfig/networking/devices/ifcfg-ppp0.
> The ppp0 in ifcfg- depends on what you named your dial up connection. By the
> way the permissions are initially 600 root:root for that file. Hope this
> helps.

That's exactly my problem.  I had just came to the same conclusion after reading
the source of rp3 and running rp3 from inside ltrace.

The button for manipulating the interface (in my case 'ppp0') only shows up if
the file /etc/sysconfig/networking-scripts/ifcfg-ppp0 contains the line "USERCTL
= true" (or "yes", "t", "y", case insensitive).

My ifcfg-ppp0 does indeed contain that line.  However if the file is 600 for
root.root, rp3 running as non-root user cannot even open it, let alone reading
the content of it.

BTW, the three files /etc/sysconfig/network-scripts/ifcfg-ppp0,
/etc/sysconfig/networking/devises/ifcfg-ppp0, and
/etc/sysconfig/networking/profiles/default/ifcfg-ppp0 are hard links to each other.
Comment 9 Weiqi Gao 2002-03-07 07:59:10 EST
Just to follow up on my post a minite ago.  The quoted passage was due to Jason
Smith (jvsmith at midamer dot net).
Comment 10 Craig McCluskey 2002-03-22 00:49:14 EST
I followed the instructions about:

- removing /etc/wvdial.conf and any file in 
	/etc/sysconfig/network* that relates to ppp0.
- run rp3-config as root and add account and modem.
- chmod 644 /etc/sysconfig/network-scripts/ifcfg-ppp0

And indeed, I can add an RH PPP Dialer applet to the Gnome panel of an ordinary
user that looks like the one root has. I clicked on it, it dialed the modem, and
I surfed the web.

Everything's great!

At least until I try to disconnect the modem! Now I get an error message popup
that says, "Warning! Failed to deactivate interface."

Help!

Thanks,

Craig
Comment 11 Craig McCluskey 2002-03-23 18:55:57 EST
 Well, I rebooted my system (for other reasons) and tried it
 again today and it worked. Don't ask me why.

 Thanks,

 Craig
Comment 12 Bill Nottingham 2006-08-07 13:16:41 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 13 Bill Nottingham 2006-10-18 10:19:53 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.