This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 556098 - torque : does not adhere to Static Library Packaging Guidelines
torque : does not adhere to Static Library Packaging Guidelines
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: torque (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Garrick Staples
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-16 09:47 EST by Michael Schwendt
Modified: 2010-06-02 11:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 11:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2010-01-16 09:47:48 EST
The package is in need of an update because it does not adhere to
the guidelines for packaging static libraries:

  http://fedoraproject.org/wiki/Packaging:Guidelines#Packaging_Static_Libraries

The -devel package contains both the shared and the static build of
a library. That makes it possible to link statically with the -devel
package as a build requirement instead of having to build-require a
special-purpose -static subpackage.

Correct would be to either disable/delete the static libraries at
build-time, or to %exclude them in the %files section, or to split off
a -static subpackage (if there is a compelling reason as why the static
libs should be made available).

Please consult the guidelines for the details.

[...]

libtorque-devel
    /usr/lib/libtorque.so  <=>  /usr/lib/libtorque.a
Comment 1 Michael Schwendt 2010-02-16 15:29:36 EST
Closed by: fedora-report-static-batch.py
Comment 2 Michael Schwendt 2010-02-16 15:32:24 EST
Still reproducible. Reopened by: fedora-report-static-batch.py

libtorque-devel
    /usr/lib/libtorque.so  <=>  /usr/lib/libtorque.a

libtorque-devel
    /usr/lib/libtorque.so  <=>  /usr/lib/libtorque.a
Comment 3 Michael Schwendt 2010-03-11 12:12:58 EST
Only "perl-PBS" in Fedora BuildRequires libtorque-devel and links shared.
Comment 4 Bug Zapper 2010-03-15 10:04:49 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Tom "spot" Callaway 2010-06-02 11:16:01 EDT
Fixed in rawhide: torque-2.4.8-1

Note You need to log in before you can comment on or make changes to this bug.