Bug 55619 - Installation of Open/StarOffice causes X session and machine to hang
Installation of Open/StarOffice causes X session and machine to hang
Status: CLOSED DUPLICATE of bug 31879
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://www.openoffice.org/issues/show...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 18:14 EST by Andrew Plumb
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-02 19:30:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Plumb 2001-11-02 18:14:37 EST
Description of Problem:

See bug report at OpenOffice.org (ID 2108).  My IBM T21 uses an S3 Savage/MX 
chipset; "86C270-294 Savage/MX-/IX as reported by the Gnome Hardware 
Browser.

Here's the initial text I included in the OpenOffice bug report, for the record:

Tried installing OpenOffice638C, StarOffice 6.0Beta and StarOffice 5.2 binaries on 
a fresh Red Hat 7.2 installation and installer hangs.

Symptomes:  GUI does not redraw, X artifacts appear on screen, mouse movement 
slows, Ctrl+Alt+Backspace won't kill X session, Ctrl+Alt+F1 won't toggle to CLI.

Other info:  Occurs in Gnome and KDE, new glibc patches do not solve problem.  
Have not tried kernel upgrade yet, or compiling OpenOffice from source.

Hardware:  IBM ThinkPad T21 laptop.  I have to pull the power and batteries to 
escape this hang - thank goodness for the ext3 file system!

Other:  This is most likely an RH7.2 problem, not a Open/StarOffice problem. 
I've given it a P1 priority since this could be quite serious if it affects all
RedHat 7.2 users.  If/when a solution appears at updates.redhat.com, it can be 
linked to from this case.


Version-Release number of selected component (if applicable):


How Reproducible:

Every Time

Steps to Reproduce:

Tried installing all of StarOffice 5.2, OpenOffice 683C and StarOffice 6.0Beta with 
the same result.

Actual Results:

Installation GUI redraws wouldn't happen, graphics artifacts manifested, mouse 
movement slowed, and eventually machine hung.  Only way to restart machine is 
to unplug power and remove battery; it's a laptop.

(Aside:  thankyou thankyou thankyou for ext3 file system; my machine comes up 
in no time as a result! :-)

Expected Results:

Successful installation.  No artifacts, and certainly not a full machine hang.

Additional Information:
 
My IBM T21 uses an S3 Savage/MX chipset; "86C270-294 Savage/MX-/IX as 
reported by the Gnome Hardware Browser.
Comment 1 Mike A. Harris 2001-11-02 20:10:07 EST

*** This bug has been marked as a duplicate of 31879 ***
Comment 2 Andrew Plumb 2001-11-02 23:35:36 EST
That did the trick!  I've updated my bugreport at OpenOffice.org to reflect the fix.

Thanks!

Comment 3 Mike A. Harris 2001-11-03 19:29:25 EST
Just to note:  Matt Galgoci also has given feedback that the new
drivers solve these problems for him also.

Note You need to log in before you can comment on or make changes to this bug.