Bug 55627 - Slows network when loaded
Slows network when loaded
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rp-pppoe (Show other bugs)
7.2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-11-02 22:07 EST by Chris Pauly
Modified: 2007-04-18 12:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 09:20:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Configuration file for RP-PPPoE (3.63 KB, text/plain)
2001-11-05 09:16 EST, Chris Pauly
no flags Details

  None (edit)
Description Chris Pauly 2001-11-02 22:07:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When using RP-PPPoE 3.2-3, upon typing "adsl-start", all network functions 
(ftp and samba in my test case), slow down drastically. RP-PPPoE 2.6-5 
(that comes with RedHat 7.1) does not exhibit this problem, and 
downgrading to this version fixes the problem. The only way i can manage 
to recover from the 3.2-3 slowdown is to reboot.

Version-Release number of selected component (if applicable):
3.2-3

How reproducible:
Always

Steps to Reproduce:
1. Start playing a movie (served up by Samba) on a different computer via 
the network.
2. Type "adsl-start".


Actual Results:  Movie plays fine until a few seconds after adsl-start is 
typed. The movie then stutters constantly and won't play properly until i 
reboot.

Expected Results:  Movie should not stutter.

Additional info:

As i said, RP-PPPoE 2.6-5 that comes with RedHat 7.1, installed onto 
RedHat 7.2, does not exhibit the problem. RP-PPPoE 3.2-3 that comes with 
RedHat 7.2, does exhibit the problem.
Comment 1 Chris Pauly 2001-11-03 02:16:03 EST
Two points that i want to make clear:

1. By rebooting, i mean that i have to reboot the RedHat box serving the movie 
to solve the problem. Only after a clean reboot without running adsl-start does 
the movie play back smoothly.
2. Not even adsl-stop will fix the network slowdown. Rebooting seems like the 
only way.
Comment 2 Ngo Than 2001-11-05 05:33:13 EST
strange, i cannot reproduce this problem. it works for me here
please check if you run adsl-start in debugging mode?

How could it work if you only type adsl-start? Do you have DSL configuration
under /etc/ppp/pppoe.conf


i recommend you should use ifup/ifdown to start/stop DSL connection instead
adsl-start/adsl-stop
Comment 3 Chris Pauly 2001-11-05 07:20:50 EST
adsl-start is not running in debug mode, no.

Yes, i have my configuration in /etc/ppp/pppoe.conf.

I'm not sure how to use ifup/ifdown. I can't seem to find any information on 
it. Could you point me to a resource on the web? Why isn't adsl-start/adsl-stop 
the best way to connect/disconnect? The HOWTO on rp-pppoe's website doesn't 
mention ifup/ifdown at all, only adsl-start.

I don't know what other information i can give you. I just upgraded to rp-pppoe 
3.2-3 to try it again, started playing a movie over the network (it's running 
fine and smooth), typed adsl-start, and within a few seconds my network has now 
slowed to a crawl again, the movie stuttering. I've downgraded to 2.6-5, run 
adsl-start adsl-stop, tried ifdown eth0 then ifup eth0, and the problem 
persists. What else can i try apart from rebooting? By the way, 'top' shows 94-
97% idle CPU time.
Comment 4 Ngo Than 2001-11-05 08:13:59 EST
we have a new config tool 'redhat-config-network' in 7.2, which allows you to
setup your network/dialup/DSL ...

This new config tool puts all the configuration fies under
/etc/sysconfig/network-scripts/ (for DSL /etc/sysconfig/network-scripts/ifcfg-ppp0)

To start/stop DSL connection just do ifup/ifdown ppp0 

could you please give me your /etc/ppp/pppoe.conf?
Comment 5 Chris Pauly 2001-11-05 09:16:24 EST
Created attachment 36449 [details]
Configuration file for RP-PPPoE
Comment 6 Chris Pauly 2001-11-05 09:19:57 EST
I tried the redhat-config-network tool, and then did ifup ppp0 with rp-pppoe 
3.2 and i still had the same problems.

By the way, does it matter that i am using the same ethernet card for both ADSL 
and my LAN? I have set up eth0 as 192.168.3.1, and ADSL to use eth0, and i am 
doing the tests on eth0/192.168.3.1.
Comment 7 Ngo Than 2001-11-05 09:45:07 EST
of course the network slow down drastically if you use the same ethernet card
for both ADSL and LAN !

In normal case it won't work!

To fix this problem you have to have 2. network adapter for your DSL

Comment 8 Chris Pauly 2001-11-05 09:55:46 EST
But why does RP-PPPoE 2.6 work fine, and 3.2 doesn't? And why, even when i adsl-
stop/ifdown, does the network remain slow and bugged? This shouldn't happen and 
it points clearly towards a bug in 3.2. I should be able to use LAN and ADSL 
via the same ethernet card. The ethernet card is 100Mbps FD plugged into a 
100Mbps FD switch with the ADSL modem on the switch's uplink. Even with ADSL 
downloading at its maximum speed (512Kbps mine is), i should still get (and do 
get with RP-PPPoE 2.6) ~9+MB/s via the LAN.
Comment 9 Ngo Than 2001-11-05 10:45:14 EST
please try ftp://people.redhat.com/than/7.2/rp-pppoe-3.3-2
Comment 10 Chris Pauly 2001-11-05 22:32:30 EST
It works! There is no slowdown on my network after running adsl-start. The 
movie is still running smoothly and ftp is getting 8.5-9.5MB/s, even while 
downloading at maximum speed via ADSL. Great! Thanks! I wonder what the problem 
with 3.2 was?

Note You need to log in before you can comment on or make changes to this bug.